Bug 16639 - Application 'TicTacToe gets hanged after posting mesage
Summary: Application 'TicTacToe gets hanged after posting mesage
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 7.0.4.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Timothy Risi
URL:
Depends on:
Blocks:
 
Reported: 2013-12-06 06:30 UTC by Prashant manu
Modified: 2013-12-10 06:41 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Prashant manu 2013-12-06 06:30:54 UTC
Steps to reproduce:
1. Open iOS Sample 'TicTacToe'.
2. Debug or run the sample.
3. Click on Messages option.
4. Click on Edit icon and type any text.
5. Click Post button.

Actual Result: Application gets hanged.

Expected Result: User should able to post message.

Supplement info:
iOS Device Log: https://gist.github.com/saurabh360/f75e84c0bcd6b5f1bbf9

Environment details
All Mac and Windows
X.S 4.2.2(build 2)
Mono 3.2.5
iOS for VS 1.10.25
X.iOS 7.0.5.2

Device info:
iPhone4s version 7.0.4
iPad2 Version 7.0.4

Regression status: This was working fine as mentioned in https://bugzilla.xamarin.com/show_bug.cgi?id=15384#c1
Comment 1 GouriKumari 2013-12-06 12:33:44 UTC
Risi,

Could you take a look at TicTacToe sample. 

Issue:
After posting a message, user is unable to navigate away from the screen and the app doesn't respond.

Test Env:
Xamarin Studio
Version 4.3.0 (build 52)
Installation UUID: 5ed3a124-4b77-4c6f-beb9-c830fd815e2a
Runtime:
	Mono 3.2.5 ((no/964e8f0)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302050000

Apple Developer Tools
Xcode 5.0.1 (3335.23)
Build 5A2053

Xamarin.iOS
Version: 7.0.5.2 (Enterprise Edition)
Hash: 9c42159
Branch: 
Build date: 2013-02-12 20:04:08-0500

Device:
iPhone5, 7.0.3
Comment 2 Saurabh 2013-12-10 06:41:40 UTC
Today, we have checked this issue with latest IOS sample:

App info: monotouch-samples-master-ea6fba720546d3b5b281e923a7fd119104cc396f

Now, this issue does not exist and application does not hang after posting message.

Device info: iPhone 4S (iOS 7.0.4)

Build info:
XS 4.2.2 (build 2)
X.iOS 7.0.5.2 
Mono 3.2.4 ((no/294f999)

Hence, closing this issue.