Bug 1662 - Inconsistant results for "Upload to Device"
Summary: Inconsistant results for "Upload to Device"
Status: RESOLVED DUPLICATE of bug 655
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 5.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-24 14:29 UTC by ric3kg
Modified: 2011-10-24 18:42 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 655

Description ric3kg 2011-10-24 14:29:27 UTC
Please ensure your device is connected...
Connected to: 

Unhandled Exception: System.Exception: AMDeviceStartService returned: 0xe800007f
at MonoTouch.Installation.Device.StartService (MonoTouch.CoreFoundation.CFString) <0x000a7>
at MonoTouch.Installation.Installer.UploadApplication (object,System.EventArgs) <0x003fb>
at MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0006e>
at (wrapper native-to-managed) MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0003f>
at (wrapper managed-to-native) MonoTouch.CoreFoundation.CFRunLoop.CFRunLoopRun () <0x00003>
at MonoTouch.CoreFoundation.CFRunLoop.Run () <0x0000b>
at MonoTouch.Installation.Installer.InstallApplication (string) <0x000bf>
at MTouch.Main (string[]) <0x03333>

[ERROR] FATAL UNHANDLED EXCEPTION: System.Exception: AMDeviceStartService returned: 0xe800007f
at MonoTouch.Installation.Device.StartService (MonoTouch.CoreFoundation.CFString) <0x000a7>
at MonoTouch.Installation.Installer.UploadApplication (object,System.EventArgs) <0x003fb>
at MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0006e>
at (wrapper native-to-managed) MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0003f>
at (wrapper managed-to-native) MonoTouch.CoreFoundation.CFRunLoop.CFRunLoopRun () <0x00003>
at MonoTouch.CoreFoundation.CFRunLoop.Run () <0x0000b>
at MonoTouch.Installation.Installer.InstallApplication (string) <0x000bf>
at MTouch.Main (string[]) <0x03333>

The application was terminated by a signal: SIGHUP
Comment 1 Sebastien Pouliot 2011-10-24 17:01:01 UTC
This looks similar to bug #655. Are you using "wireless sync" between your computer and your device ? 

It's a new option in iTunes for iOS5 and known to cause problem with MonoTouch 5.0 (newer versions will ignore the "phantom" device). In doubt try the following command in a terminal window:

/Developer/MonoTouch/usr/bin/mtouch --listdev

and paste the result here. Thanks
Comment 2 ric3kg 2011-10-24 17:11:09 UTC
devPad: 8e8340c4423bb320c0af3826a92eb809ba0f8882
:
Comment 3 Sebastien Pouliot 2011-10-24 18:42:20 UTC
that's it, the ":" alone on a line is the phantom device (usable only for wireless sync and confusing mtouch).

Normally when it gets on the second line (if you plug/unplug your device) monotouch should work properly (connecting to the first device). But if you want to avoid the hassle then you can disable the "wireless sync" in iTunes until the new MT releases are out.

*** This bug has been marked as a duplicate of bug 655 ***