Bug 16569 - Visual Studio 2010 toolbars configuration is reset each VS launch
Summary: Visual Studio 2010 toolbars configuration is reset each VS launch
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 1.8.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-12-03 13:12 UTC by Andrew
Modified: 2015-07-17 08:47 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Andrew 2013-12-03 13:12:09 UTC
I work with "Standard" toolbar hidden to save screen real estate. Each time I launch VS, the toolbar gets visible, so I have to hide it manually. 

I started noticing this behavior since a big Xamarin update approx. last February.

Steps to reproduce:
1) launch VS 2010, hide "Standard" toolbar (keep both Xamarin's visible -- not sure it's important)
2) exit VS
3) launch it again
4) see the toolbar unhidden 


Xamarin.Android   4.10.01073 (d23a19bf)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   1.8.365 (8cb9dbd0)
Visual Studio extension to enable development for Xamarin.iOS
Comment 1 Atin 2013-12-10 08:53:51 UTC
We have checked this issue with:

VS 2010
Windows 8
MTVS 1.8.365
MFA 4.10.01073

we are not able to reproduce this issue, steps we have followed for this issue:

1. Open VS 2010
2. Create any android application or iOS application
3. Auto hide the Toolbox
4. Quit VS 
5. Relaunch the VS and open the project

Observe that Toolbar is hidden  

screencast: http://www.screencast.com/t/uoRxxQ05V

Could you please provide us some screencast?  So that we can reproduce this issue.
Comment 2 Andrew 2013-12-10 09:20:10 UTC
The step #3 in your reproduce scenario is wrong.

The problem is not with the "Toolbox" side panel, as displayed in your screencast, but with the "Standard" toolbar -- the toolbar that appears right under the menu line and contains buttons like "save", "cut", "copy", "paste" etc.

Please retest.
Comment 3 Andrew 2013-12-10 09:46:16 UTC
Here's my screencast: http://www.screencast.com/t/twTVIBftZQ

Though I wasn't able to reproduce this issue on a new empty project, it seems to exist for one my solution only (just for sure I erased *.suo file as well as solution-specific settings file, but it didn't helped)
Comment 4 Atin 2013-12-10 10:00:43 UTC
@Andrew thanks for correcting me.

We are also not able to reproduce this issue with new project. Could yo please attach your project here?
So we can reproduce this issue at our end.
Comment 5 Andrew 2013-12-10 10:38:12 UTC
Unfortunately I cannot share the solution