Bug 16562 - Debug / Release / etc configuration is messed up
Summary: Debug / Release / etc configuration is messed up
Status: RESOLVED DUPLICATE of bug 19462
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 1.8.x
Hardware: PC Windows
: Normal normal
Target Milestone: 3.10
Assignee: Ian Ceicys
URL:
Depends on:
Blocks:
 
Reported: 2013-12-03 08:06 UTC by Andy
Modified: 2015-01-08 17:56 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
multi config (41.18 KB, image/png)
2013-12-03 13:06 UTC, Andy
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 19462

Description Andy 2013-12-03 08:06:52 UTC
Part of the dropdown is black, until you scroll it.

Besides listing all the configurations there (DEbug-simulator, Debug-iPhone, etc) is a mess and too long and confusing

It was better how it was before, one dropdown for Debug/Release/etc, one for the device
Comment 1 Mikayla Hutchinson [MSFT] 2013-12-03 12:57:38 UTC
The reason you have longer configuration-platform strings in the left combo is because those are the actual full names of the configurations. When it's possible to disambiguate configurations by the target device that they support (right combo), then we do so. If your case, your solution configurations must have become more complex so this is no longer possible.

The black popup is a dup of bug 14556.

*** This bug has been marked as a duplicate of bug 14556 ***
Comment 2 Andy 2013-12-03 13:06:17 UTC
Created attachment 5590 [details]
multi config

See screenshot. This is madness, and I didn't touch the configurations. I think your VS plugin did, so please double-check the mess it produces, because it's becoming unusable.

Even when I try to clear this mess, reopening VS recreates the situation in time, so IT IS a Xamarin VS bug
Comment 3 Andy 2013-12-03 13:06:27 UTC
See screenshot. This is madness, and I didn't touch the configurations. I think your VS plugin did, so please double-check the mess it produces, because it's becoming unusable.

Even when I try to clear this mess, reopening VS recreates the situation in time, so IT IS a Xamarin VS bug
Comment 4 Mikayla Hutchinson [MSFT] 2013-12-03 13:25:25 UTC
It's VS itself that creates those redundant configurations, not the Xamarin extensions. But maybe we can do something to suppress it.
Comment 5 Andy 2014-01-13 19:45:08 UTC
It periodically messes up Configuration Mappings too. You always have to double check before building and after reopening in XS. It's quite annoying...
Comment 7 Cody Russell 2015-01-08 17:56:08 UTC

*** This bug has been marked as a duplicate of bug 19462 ***