Bug 16551 - The list of available device in the "Target android device" bar is not correctly updated
Summary: The list of available device in the "Target android device" bar is not correc...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 0.x Insider Preview
Hardware: PC Windows
: Normal normal
Target Milestone: 1.12 (Merge)
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-12-03 00:13 UTC by pierre
Modified: 2014-02-18 09:55 UTC (History)
9 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description pierre 2013-12-03 00:13:42 UTC
Hi,

Every times I unplug a device, it correctly disappears from the target device bar ; but when I plug it back it does not reappear anymore. I am forced to close visual studio and reopen it to see it again. Same when I change the device, the new one never appears.
Comment 1 Mohit Kheterpal 2013-12-10 09:22:34 UTC
Today we have checked this issue with following builds :

VS 2013
X.Android 4.10.02010

we are also getting same issue as mention in bug description i.e. when we replug the device in VS then target device window does not updated with connected device. And device appears when we restart VS.
Comment 2 Dominique Louis 2014-02-18 09:55:22 UTC
Set to works for me in 1.12