Bug 16494 - Getting Mono.iOS.VisualStudio.Documentation has stopped working when user cancel Documentation Manager and then Start again.
Summary: Getting Mono.iOS.VisualStudio.Documentation has stopped working when user can...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 0.x Insider Preview
Hardware: PC Windows
: High normal
Target Milestone: 3.1
Assignee: Jose Miguel Torres
URL:
Depends on:
Blocks:
 
Reported: 2013-11-28 09:09 UTC by Nischal
Modified: 2014-02-17 05:45 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Nischal 2013-11-28 09:09:58 UTC
Steps to reproduce:
1. Open VS.
2. Connect VS to build host.
3. Click 'Check now' link from Tools->Option->iOS Settings
4. Click yes to sync documentation.
5. Wait for completing documentation.
6. Observe that Xamarin.iOS.Documentation Manager window appears.
7. Click Cancel button.
8. Again click Start button.

Actual result: A popup appears which is showing "Mono.iOS.VisualStudio.Documentation has stopped working".

Expected Result: Merging should start again after clicking on Start button.

Supplement info:
http://screencast.com/t/D2AJCnJT5Z
Doc Manager Log: https://gist.github.com/saurabh360/6f5fbd8ac3fd4d28af10

Environment details:
Windows 8.1
VS 2013/2012/2010
MTVS 1.10.12
X.iOS 7.0.5.0
Comment 1 Jose Miguel Torres 2013-12-10 06:20:39 UTC
Confirmed. Pull request sent...
Comment 2 Jose Miguel Torres 2013-12-10 07:04:33 UTC
Fixed at XamarinVS/master commit eaa8fe63245851e9ac8581e5f5666a627e368df8
Comment 3 Prashant manu 2013-12-11 06:54:08 UTC
I have checked this issue with following builds:

Win 8.1
VS 2013/2012
MTVS 1.10.30
X.iOS 7.0.5-2

I am still seeing this issue.
http://screencast.com/t/lDW3Zpue 
Doc Manager Log: https://gist.github.com/saurabh360/fc317299519bb9e7058d

Hence, reopening this issue
Comment 4 Jose Miguel Torres 2014-02-17 05:45:57 UTC
Fixed in xamarinvs|master commit 3ba1e0116bc4d123a0328864fa2c96ed8272244c