Bug 16400 - Unhandled activation error
Summary: Unhandled activation error
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Activation ()
Version: 4.2.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Bojan Rajkovic [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2013-11-22 04:24 UTC by folex
Modified: 2014-04-28 13:58 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin Studio logs (1.96 KB, application/zip)
2013-12-02 03:23 UTC, folex
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description folex 2013-11-22 04:24:37 UTC
So happened that I changed HDD in my macbook. I've reinstalled Studio, then as usually activated it via "offline" activation, and now when I run Studio, it gives me "Unhandled activation error" error. After logging in, it gives me another "Unhandled activation error":

"Information for support":
System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
  at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x0030c] in /private/tmp/source/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-3.2.4/mcs/class/System/System.Net/HttpWebRequest.cs:1606 
  at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00141] in /private/tmp/source/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-3.2.4/mcs/class/System/System.Net/HttpWebRequest.cs:1423 


I'd be glad to revoke existing license and add a new one, but we exceeded limit of license revoking (3 macbooks broken in 4 months).

P.S. Support on email doesn't answer me.
Comment 1 folex 2013-11-22 04:43:36 UTC
Xamarin Studio
Version 4.2.1 (build 1)
Installation UUID: 1fb7cea0-62ac-4b6f-9af0-40372b2fb05f
Runtime:
	Mono 3.2.4 ((no/294f999)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302040000
Comment 2 folex 2013-11-22 05:19:40 UTC
Xamarin Studio reinstall fixed issue.
Comment 3 Mikayla Hutchinson [MSFT] 2013-11-23 16:28:55 UTC
Temporary issue in the activation servers, should be fixed. Thanks for the report!

Note that just logging back into XS again should restore your licenses.
Comment 4 folex 2013-11-25 00:33:42 UTC
It wasn't "temporary at all". It's repeated about 2 days with short "break" while I was able to use XS with offline activation (about 5hrs).
Moreover, it's happened again. I don't wont start my every work day with reinstall of XS.
Comment 5 folex 2013-11-26 07:40:45 UTC
The main difference between successful and unsuccessful activation is that login for successful one goes through browser and unsuccessful one through XS's dialog.
Comment 6 folex 2013-11-26 07:41:33 UTC
It persists over week already. Every working day I start from reinstalling Xamarin Studio.
Comment 7 PJ 2013-11-26 12:44:41 UTC
Hi Folex, sorry to hear of the trouble.

I need a little bit more information to figure out what's causing the problem for you - there should be nothing about re-installing Xamarin Studio that would fix this issue for you, and I agree - re-installing every day would be a pain.

When you log in and log out of a 'broken' Xamarin Studio install, is the error you get the exact same as the original description?

Beyond additional description, we'll probably need to take a look at your most recent logs files. You can access the log directory through the Xamarin Studio -> Help -> Open Log Directory menu option.

Hopefully with that information we can see what's causing the issue for you. The other thing I'm wondering  is whether or not the Xamarin Studio version is staying consistent. From comment 5 it seems like you're using both a 4.2 version of Xamarin Studio and a 4.0 version. The 4.0 version logs in through the browser, the 4.2 version logs in through the IDE.

Thanks for the information!
Comment 8 folex 2013-11-29 04:24:35 UTC
Well, it doesn't happen anymore.
I'll comment this bug if it happens again.
Comment 9 folex 2013-12-02 03:22:17 UTC
> When you log in and log out of a 'broken' Xamarin Studio install, is the error you get the exact same as the original description?

Yes
Comment 10 folex 2013-12-02 03:23:50 UTC
Created attachment 5576 [details]
Xamarin Studio logs

I've deleted all logs, restarted XS and then tried to relogin. All of generated logs are in zip (except symlink).
Comment 11 folex 2013-12-02 03:28:08 UTC
Forgot to mention: It's always happens after installing any update (this time it was upgrade to XS 4.2.1)
Comment 12 Bojan Rajkovic [MSFT] 2013-12-11 09:41:49 UTC
I don't see anything useful in the log files. There was a brief period of time that this might have been an issue, but I can't reproduce anymore. Are you still having problems?
Comment 13 folex 2013-12-13 06:25:18 UTC
Yes, after every XS update, I have exactly same problem.
Comment 14 folex 2014-02-06 02:45:06 UTC
Well, I didn't install any updates in 2 months. Yesterday I've took risk and update my Xamarin Studio. Everything was OK till today. Now I have same error. I kinda hate you guys.
Comment 15 Bojan Rajkovic [MSFT] 2014-02-14 17:12:25 UTC
I can't seem to reproduce, through 3 months of upgrades. If you can provide logs again from that day, I'll happily look at them, but I haven't seen any reports of this happening to anyone else.
Comment 16 folex 2014-03-28 04:04:10 UTC
Well, it's finally fixed in 7.2.
Comment 17 Bojan Rajkovic [MSFT] 2014-04-28 13:58:23 UTC
Reported fixed.