Bug 16383 - Regression: Find Next does not work after switching to a different document
Summary: Regression: Find Next does not work after switching to a different document
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.2.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-11-21 07:25 UTC by chris
Modified: 2013-11-22 00:24 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description chris 2013-11-21 07:25:13 UTC
After doing a "Find" or "Find Next Selection" it's no longer possible to switch to a 
different document and continue with "Find Next".

This was first fixed in 5305 and has been working for the past 6 months on stable.

It would be great if this could be fixed for the next update.
Comment 1 Akhilesh kumar 2013-11-21 08:49:05 UTC
Can you please add a screencast so that we can reproduce this issue.
Comment 2 chris 2013-11-21 13:56:58 UTC
No idea about a screencast but I can give you a repro:

- start Xamarin Studio
- open a project
- open any .cs
- use "Find" to search for "class"
- switch to another .cs
- use "Find Next"

Result:
- it doesn't find anything

Expected:
- it should find "class"
Comment 3 narayanp 2013-11-21 23:35:42 UTC
I have checked this issue with following builds:

All Mac
X.S 4.2.1(build 1)
Mono 3.2.4
X.iOS 7.0.4.209
X.Android 4.10.1-68

I am unable to reproduce this issue. This is the screencast for the same: http://screencast.com/t/BO0PAjs2H

@Chris, Could you please check it on latest builds?
Comment 4 Mike Krüger 2013-11-22 00:23:15 UTC
fixed (I think that's easy to reproduce)

it was a side effect of the https://bugzilla.xamarin.com/show_bug.cgi?id=13376 fix btw.
Comment 5 Mike Krüger 2013-11-22 00:24:16 UTC
Note: if a search occured in the other text editor before find next works as expected - you need to open a new file and not open the find panel in that one to be able to reproduce the bug.