Bug 16361 - TypeDescriptor ignores the registered type descriptors
Summary: TypeDescriptor ignores the registered type descriptors
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib ()
Version: master
Hardware: All All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-20 07:20 UTC by MoonStorm
Modified: 2015-02-04 09:50 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Type Descriptor Tests (5.60 KB, text/plain)
2013-11-20 07:20 UTC, MoonStorm
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description MoonStorm 2013-11-20 07:20:39 UTC
Created attachment 5485 [details]
Type Descriptor Tests

Trying to add a custom type descriptor for an expando object, I stumbled upon a buggy TypeDescriptor, where multiple shortcuts were taken in its implementation just to fulfill a basic functionality.

I've attached four tests, all of them failing on Mono. Looking at the source code, it seems the TypeDescriptor completely ignores the registered type descriptors when asked to retrieve attributes, properties, events, etc via direct calls. 

A workaround could be going via GetProvider and ask for the same info, but that means changing all the 3rd party libraries as well, for which the source code is not always available.
Comment 1 Marek Safar 2015-02-04 09:50:08 UTC
Fixed in master