Bug 16290 - Could not build zip for distribution
Summary: Could not build zip for distribution
Status: VERIFIED DUPLICATE of bug 16194
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 7.0.4.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-15 17:44 UTC by Jason Leach
Modified: 2013-12-16 10:42 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 16194

Description Jason Leach 2013-11-15 17:44:19 UTC
Builds when I say build, with warnings,  crashes and burns when I say zip application bundle.


Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" --cache "/Users/jason/Projects/LightspeedXS/LSMobile/obj/iPhone/Distribution/mtouch-cache" --nomanifest --nosign -dev "/Users/jason/Projects/LightspeedXS/LSMobile/bin/iPhone/Distribution/LSMobile.app" -r "/Developer/MonoTouch/usr/lib/mono/2.1/System.dll" -r "/Developer/MonoTouch/usr/lib/mono/2.1/System.Xml.dll" -r "/Developer/MonoTouch/usr/lib/mono/2.1/System.Core.dll" -r "/Developer/MonoTouch/usr/lib/mono/2.1/monotouch.dll" -r "/Developer/MonoTouch/usr/lib/mono/2.1/System.Web.Services.dll" -r "/Developer/MonoTouch/usr/lib/mono/2.1/System.Data.dll" -r "/Developer/MonoTouch/usr/lib/mono/2.1/MonoTouch.Dialog-1.dll" -r "/Users/jason/Projects/LightspeedXS/Components/sqlite-net-1.0.1/lib/ios/SQLite.dll" -sdk "7.0" -targetver "5.0" --abi=armv7 "/Users/jason/Projects/LightspeedXS/LSMobile/bin/iPhone/Distribution/LSMobile.exe"
Xamarin.iOS 7.0.4 Business Edition using framework: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS7.0.sdk
warning MT3005: The dependency 'Mono.Data.Tds, Version=2.0.5.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' of the assembly 'System.Data, Version=2.0.5.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' was not found. Please review the project's references.
warning MT3005: The dependency 'System.Json, Version=2.0.5.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' of the assembly 'MonoTouch.Dialog-1, Version=0.0.0.0, Culture=neutral, PublicKeyToken=84e04ff9cfb79065' was not found. Please review the project's references.
warning MT3006: Could not compute a complete dependency map for the project. This will result in slower build times because Xamarin.iOS can't properly detect what needs to be rebuilt (and what does not need to be rebuilt). Please review previous warnings for more details.
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
System.NullReferenceException: Object reference not set to an instance of an object
  at MonoTouch.Tuner.InternalPInvoke.GetEntryPoints (Mono.Linker.LinkContext context) [0x00000] in <filename unknown>:0 
  at MonoTouch.Application.StripNativeCode () [0x00000] in <filename unknown>:0 
  at MonoTouch.Application.Build () [0x00000] in <filename unknown>:0 
  at MTouch.Main2 (System.String[] args) [0x00000] in <filename unknown>:0 
  at MTouch.Main (System.String[] args) [0x00000] in <filename unknown>:0
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-11-18 08:43:22 UTC
I believe this is a duplicate of bug #16194 - but can you zip up and attach [1] the contents of the obj/iPhone/*/mtouch-cache directory, as well as the complete build output when doing a *re*build (not
only build) so that we can confirm?

[1] You'll probably have to use dropbox or a similar service, since it'll be
too big for an attachment.
Comment 2 Sebastien Pouliot 2013-12-12 10:25:27 UTC
Likely dupe. Re-open (with a test case) if this still occurs with 7.0.6.

*** This bug has been marked as a duplicate of bug 16194 ***
Comment 3 Mohit Kheterpal 2013-12-16 10:42:56 UTC
As this issue is duplicate of bug 16194, and bug 16164 is verified fixed.

Hence closing this issue. Changing its status to verified.