Bug 16227 - Can not build IPA
Summary: Can not build IPA
Status: VERIFIED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.8.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-14 08:52 UTC by Szilárd Széll
Modified: 2015-07-21 14:25 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED NORESPONSE

Description Szilárd Széll 2013-11-14 08:52:00 UTC
Try to build a Configuration where IPA building is enabled.

Mono.IOS.VisualStudio.MonoTouchDeploySession Critical: 0 : Unhandled exception while building remotely
System.InvalidOperationException: The operation cannot be completed because a build is already in progress.
   at Microsoft.Build.Shared.ErrorUtilities.ThrowInvalidOperation(String resourceName, Object[] args)
   at Microsoft.Build.Execution.BuildManager.BeginBuild(BuildParameters parameters)
   at Microsoft.Build.Execution.BuildManager.Build(BuildParameters parameters, BuildRequestData requestData)
   at Mono.IOS.VisualStudio.MonoTouchDeploySession.RemoteBuild(VSBuildServerClient server, Project project, IVsOutputWindowPane outputPane, MonoTouchProgressNotifier notifier)

[14-Nov-2013 14:45:08] mtouch 7.0.4.209 (23a0827)
Comment 1 Mohit Kheterpal 2013-11-20 06:32:40 UTC
Today we have checked this but unable to reproduce this issue with following builds :

VS 2013
MTVS 1.8.365
MT 7.0.4.209

We are successfully able to build IPA

We have checked this issue via following steps :
1. Select Build Adhoc/Enterprise package (IPA) under iOS IPA option in project properties. 
2. And run the project.
3. Project is successfully deployed on device

Can you please provide some Steps(or Screencast) and Environment details so that we can reproduce this issue over here.
Comment 2 Enzo Heredia 2015-06-30 12:43:08 UTC
not reproducible in XMA build 4.0.0.307
Comment 3 Mohit Kheterpal 2015-07-16 09:07:30 UTC
As per comment 1, there is no response from "2013-11-20". So I am closing this issue as "Resolved Noresponse"

Thanks