Bug 16220 - After updates are downloaded, I get "Updates require authorization"
Summary: After updates are downloaded, I get "Updates require authorization"
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Updater ()
Version: 4.1.13
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-14 06:39 UTC by Magnus Johansson
Modified: 2017-05-10 23:35 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screen shot of error (41.97 KB, image/png)
2013-11-14 06:39 UTC, Magnus Johansson
Details
Updater log file (3.10 KB, application/octet-stream)
2013-11-15 03:46 UTC, Magnus Johansson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Magnus Johansson 2013-11-14 06:39:49 UTC
Created attachment 5421 [details]
Screen shot of error

Description of Problem:
After the latest updates has been downloaded, I get this error message:
"Error, updates require authorisation"

Steps to reproduce the problem:
1. Start Xamarin Studio on OSX 10.9
2. Download updates
3. Observe error message


Actual Results:
Error message as stated above

Expected Results:
Either the updates can be installed, or at least prompt me to start elevated (in Sudo?)

How often does this happen? 
Every time

Additional Information:
MAC OSX 10.9
Comment 1 Mikayla Hutchinson [MSFT] 2013-11-14 17:55:25 UTC
Strange, that error indicates that that it attempted to elevate but failed.

Could you please attach the updater log from ~/Library/Logs/XamarinStudio-4.0/Updater.log?
Comment 2 Magnus Johansson 2013-11-15 03:41:32 UTC
Today, when I tried again, it succeeded and prompt me for my credentials, as expected.
Log file attached,
Comment 3 Magnus Johansson 2013-11-15 03:46:01 UTC
Created attachment 5439 [details]
Updater log file

Well, this was not especially useful. It seems that the updater overwrites the log file instead of appending to it...
Comment 4 Mikayla Hutchinson [MSFT] 2013-11-15 14:24:33 UTC
Ah. Not much I can do until I get a repro or a log from a failed update. Glad it worked the next time round anyway!
Comment 5 Mikayla Hutchinson [MSFT] 2013-11-15 14:25:25 UTC
I'll leave the bug in NEEDINFO state for now, in case someone else encounters this and can provide the info.
Comment 6 Tommy Sadiq Hinrichsen 2014-01-18 15:15:01 UTC
I have the same issue, pasted log file here http://forums.xamarin.com/discussion/12475/update-requires-authorization
Comment 7 Tommy Sadiq Hinrichsen 2014-01-18 16:07:54 UTC
I have the same issue, pasted log file here http://forums.xamarin.com/discussion/12475/update-requires-authorization
Comment 8 Kirill Osenkov 2017-05-10 23:35:04 UTC
Unfortunately we don't have enough information to do anything about this right now, especially since 3 years have passed. We're resolving this for now.