Bug 16203 - configuration error for build: No rule to make target `../../mono/mini/libmono-2.0.la
Summary: configuration error for build: No rule to make target `../../mono/mini/libmon...
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: 3.2.x
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2013-11-13 15:51 UTC by Jonathan Shore
Modified: 2017-07-08 03:22 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Jonathan Shore 2013-11-13 15:51:58 UTC
I need to be able to build mono with loadable llvm (not statically compiled in).  I have tried building both the HEAD and the 3.2.3 tar ball, using the config:

autogen.sg | configure --prefix=… --enable-llvm=yes --enable-loadedllvm
make
...

make[4]: *** No rule to make target `../../mono/mini/libmono-2.0.la', needed by `libmono-llvm.la'.  Stop.
make[4]: Leaving directory `/home/jonathan/Srcs/mono-3.2.3/mono/mini'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/jonathan/Srcs/mono-3.2.3/mono/mini'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/jonathan/Srcs/mono-3.2.3/mono'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jonathan/Srcs/mono-3.2.3'

Can someone fix the config so that the right makefiles are produced.  Thanks
Comment 1 Zoltan Varga 2013-12-02 22:02:51 UTC
Could you try again with master ? If it doesn't work, I'd suggest avoiding the --enable-loadedllvm argument, its a bit fragile.
Comment 2 Ludovic Henry 2017-07-08 03:22:34 UTC
Can you still reproduce with latest mono? If that's the case, feel free to reopen, and please provide a repro case. Thank you.