Bug 16171 - Have to reinstall Xamarin Studio after every Xcode update
Summary: Have to reinstall Xamarin Studio after every Xcode update
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 7.0.4.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-12 21:41 UTC by david
Modified: 2014-09-22 10:50 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description david 2013-11-12 21:41:50 UTC
This is getting to be a bit of a pain. Every time Xcode is updated (which after Xcode 5 has been a lot) I have to reinstall Xamarin Studio on my Mac.

Please place the whatever-it-is-that-makes-it-work somewhere where Xcode's updates can't destroy it.

Alternatively, instead of bleating that it can't build my iOS project any more, please have Xamarin Studio download the relevant stuff and fix the problem itself.

The current situation is a nasty productivity killer.

Thanks!
Comment 1 Jeffrey Stedfast 2013-11-13 06:52:37 UTC
What errors are you getting? I've never had to reinstall after updating Xcode...
Comment 2 david 2013-11-13 21:52:20 UTC
I updated Xcode 5 to its latest version yesterday.

When I opened my iOS projects in Xamarin Studio, they were coloured red and weren't able to build.

A message came up saying something like "you need to install Xamarin for iOS, please download it from Xamarin.com" (can't remember the exact wording, sorry).

I went to the site, downloaded the dmg, opened it, ran the installer, and now my iOS projects are build able again.

HTH
Comment 3 Jeffrey Stedfast 2013-11-13 21:54:49 UTC
Maybe Xcode deleted /Developer/MonoTouch? I dunno.
Comment 4 david 2013-11-13 22:00:06 UTC
Seems like it wipes out something that Xamarin needs. Hence the request for Xamarin to either reinstall automatically (it knows what's missing, after all, and it tells me where to go get it!) or to store that critical piece somewhere where Xcode won't touch it.

TIA
Comment 5 Rolf Bjarne Kvinge [MSFT] 2013-11-14 09:51:31 UTC
It's been years since I've seen this happen.

Did you happen to have an old version of Xcode in /Developer (~v4.2 I believe was the last version to be installed there)?
Comment 6 david 2013-11-14 15:55:44 UTC
No, this issue is all about Xcode 5. Bog-standard install, downloaded from Apple, etc.

It's been happening since Xcode 4, but the present problems also persist with Xcode 5.

Thanks
Comment 7 Rolf Bjarne Kvinge [MSFT] 2014-09-22 10:50:11 UTC
This is resolved with Xamarin.iOS 7.4 (we install into /Library/Frameworks/Xamarin.iOS.framework instead of /Developer).