Bug 1615 - MJ12node.exe deadlocks when using SGen
Summary: MJ12node.exe deadlocks when using SGen
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: GC ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-20 13:53 UTC by Kari Takanen
Modified: 2011-12-28 07:02 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
gdb output (9.62 KB, text/plain)
2011-10-20 13:53 UTC, Kari Takanen
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Kari Takanen 2011-10-20 13:53:31 UTC
Created attachment 738 [details]
gdb output

The program MJ12node (http://www.majestic12.co.uk) often deadlocks when using SGen. Haven't seen it happening with Boehm.

Attached is output from gdb as described in http://www.mono-project.com/Debugging#Debugging_Unmanaged_Deadlocks.

Mono version used: Mono JIT compiler version 2.11 (master/63de171 Thu Oct 20 16:59:08 EEST 2011)
OS: Ubuntu 11.10 64-bit

Please let me know if you need more info or debug data.
Comment 1 Zoltan Varga 2011-10-21 04:55:37 UTC
Probably a dup of:
https://bugzilla.novell.com/show_bug.cgi?id=683475
Until that bug is fixed, this app won't run on mono, no use in trying.
Comment 2 Kari Takanen 2011-10-21 06:09:13 UTC
Not sure about that, since the deadlock happens when the content analyzer is _not_ running. It's just basically downloading lots of stuff via HTTP.. but it could of course be the same bug happening in different place, I don't know.

And the app surely runs on Mono but just sometimes crashes / deadlocks / otherwise misbehaves. Have to live with that. :)
Comment 3 Rodrigo Kumpera 2011-12-28 07:02:21 UTC
Fixed on trunk