Bug 16110 - Xamarin Studio freezes when selecting a .net solution or project
Summary: Xamarin Studio freezes when selecting a .net solution or project
Status: RESOLVED DUPLICATE of bug 15596
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: ASP.Net ()
Version: 4.0.13
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-11 09:12 UTC by guivho
Modified: 2013-11-12 05:28 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Freshly created Web Application (5.09 KB, application/zip)
2013-11-11 09:12 UTC, guivho
Details
Log after killing hanging XS (3.41 KB, application/zip)
2013-11-12 02:40 UTC, guivho
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 15596

Description guivho 2013-11-11 09:12:47 UTC
Created attachment 5391 [details]
Freshly created Web Application

Xamarin Studio freezes immediately after creating a new Web Application. The Default.aspx file is highlighted and the rainbow disc starts spinning and does not stop anymore.

I attach the project, but this happens as well for any existing .net project that I open.

I am using the latest XS 4.0.13 (build 38).

Please advise
Comment 1 guivho 2013-11-11 09:36:01 UTC
I just tried to reopen this blank project, and it succeeded, albeit complaining that button1 does not have a Text member!

So I closed XS and restarted it to verify.

I open the project and the cursor sits on the solution name. Hitting down arrow gets the cursor spinning again without stopping. I had to kill it again.

For what it's worth: when I try to open an old multi-project sloution and select one of the projects, the disk also starts spinning. At that point msbuild.exe also seems to be running:

    2658 /Applications/Xamarin Studio.app/Contents/MacOS/XamarinStudio
    2666 /Library/Frameworks/Mono.framework/Versions/3.2.0/bin/mono /Applications/Xamarin Studio.app/Contents/MacOS/lib/monodevelop/bin/MSBuild/4.0/MonoDevelop.Projects.Formats.MSBuild.exe

With the freshly created Web Application the MSBuild is not running.
Comment 2 guivho 2013-11-11 09:37:12 UTC
For sake of completeness: ios apps build and run as expected without problems.
Comment 3 Mikayla Hutchinson [MSFT] 2013-11-11 15:15:03 UTC
Could you try with the 4.2.0.7 beta?
Comment 4 guivho 2013-11-11 17:03:38 UTC
Same problem (I only installed the beta of XS, not of the framework)
Comment 5 Mikayla Hutchinson [MSFT] 2013-11-11 17:26:46 UTC
Can you please run  "killall -QUIT XamarinStudio" when XS is hung, then find and attach the log file from ~/Library/Logs/XamarinStudio-4.0?
Comment 6 guivho 2013-11-12 02:40:59 UTC
Created attachment 5396 [details]
Log after killing hanging XS
Comment 7 Mikayla Hutchinson [MSFT] 2013-11-12 03:06:09 UTC
Thanks, it's a known bug in the vi mode that's been fixed already.

*** This bug has been marked as a duplicate of bug 15596 ***
Comment 8 guivho 2013-11-12 05:28:43 UTC
Disabling vi mode gets rid of the problem.

Thanks