Bug 16035 - Inconsistent results from PURCHASE workflow
Summary: Inconsistent results from PURCHASE workflow
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 3.0
Hardware: PC All
: Highest critical
Target Milestone: ---
Assignee: vsx
URL:
: 15989 ()
Depends on:
Blocks:
 
Reported: 2013-11-08 05:10 UTC by Prashant manu
Modified: 2016-03-29 16:31 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Prashant manu 2013-11-08 05:10:40 UTC
Condition: User should logged in with Trial account.

Steps to reproduce:
1. Open VS.
2. Observe that used logged in wit Trail account and activated with trial.
3. Go to taco.xamstage.com and purchase a business/priority license with same account.
4. Observe that user successfully purchased business/priority
5. Now restart VS.

Actual Result: User showing STARTER instead of business/priority license on Xamarin account window.

Expected Result: User should be activated with business/priority license.

Supplement Info:
http://screencast.com/t/vsvHzzpjj

Environment details:
All Windows and Mac
VS 2013/2012/2010
X.S 4.2(build 3)
X.Android 4.10.1-57

Account Info:
8nov@gmail.com/360logica
Comment 1 PJ 2013-11-08 10:58:52 UTC
I'm trying to get the request here from Charles to see if it's hutch or bojan - CCing both for now.
Comment 2 PJ 2013-11-08 11:15:12 UTC
When I come back from the purchase I'm seeing the INTERNET workflow, and then canceling that gives me a web exception:

System.Net.WebException: The operation has timed out
at Xamarin.Components.Ide.Activation.ActivationService.GetErrorWorkflow(LicenseSyncResult[] results, Boolean isBackground)
at Xamarin.Components.Ide.Activation.ActivationService.<GenerateFullWorkflowSequence>d__8c.MoveNext()
at Xamarin.Components.Ide.Activation.ActivationDialog.DisplayWorkflowStep(ActivationWorkflowStep step)
at Xamarin.Components.Ide.Activation.ActivationDialog.HandleWorkflowAction(ActivationWorkflowAction action)

With Charles, I can't seem to get SSL to work, even after enabling SSL proxying on what I assume to be all the relevant servers.

However, then after I turned off Charles, I was able to successfully complete a purchase.

http://screencast.com/t/DkQv4Wa0

So without using Charles I have seen both a positive and negative result over the last 10 minutes. With Charles I can't get anything to work yet to debug more.
Comment 3 PJ 2013-11-08 11:24:46 UTC
I've now been able to successfully run the purchase case a few times in a row. 360logica is trying more and will update with additional logs etc.
Comment 4 Atin 2013-11-08 11:35:13 UTC
An update to the above issue:

VS Debug output: https://gist.github.com/saurabh360/4d2e9827ca7bc1c062a8

We are also getting inconsistent behavior, sometimes we are able to purchase and redirects to VS successfully. But most of the time unable to redirects
Comment 5 PJ 2013-11-08 11:35:33 UTC
I got the issue where I see the INTERNET workflow and then canceling shows me a web exception again:

http://screencast.com/t/coUoZqxuva

I'm also logged out of the account i was just logged into at this point.

I'm not sure if this is just server flakiness, but at the very least I shouldn't be logged out of my account when I time out.
Comment 6 PJ 2013-11-08 11:50:53 UTC
*** Bug 15989 has been marked as a duplicate of this bug. ***
Comment 7 PJ 2013-11-08 11:52:09 UTC
I get nothing in the debug output when this fails, I just get the exception I pasted above in the Trace.0 log.
Comment 8 Alan McGovern 2013-11-08 14:01:38 UTC
This issue is the one i've been seeing for a few weeks. It's random and can be fixed by logging out/logging in, or just restart VS, or just close and open the Account Dialog.

As such i don't believe this should be a blocker for release if we cannot diagnose it.
Comment 9 Mikayla Hutchinson [MSFT] 2013-11-08 15:54:46 UTC
The timeout exception reaching the UI should be fixed by md-addins/bebb23a53d987455c3241d31b550c69acdc21592
Comment 10 Mikayla Hutchinson [MSFT] 2013-11-08 15:56:36 UTC
The fact that it's timing out may be fixed by Alan's TPL fix. Can you still repro?
Comment 11 Mohit Kheterpal 2013-11-11 07:03:36 UTC
Today we have checked this issue with following builds :

VS 2013 / 2012
MTVS 1.8.342

We are still getting same issue as described in bug description.

Screencast : http://www.screencast.com/t/PCv2v2AxR
Comment 12 PJ 2013-11-11 10:57:14 UTC
I think this has  to be downgraded from blocker, I am not sure we can get any more fixes in and this wouldn't actually block.
Comment 13 Mikayla Hutchinson [MSFT] 2013-11-11 15:17:08 UTC
Do you have logs for that?
Comment 14 Alan McGovern 2013-11-12 22:38:55 UTC
Michael, this looks like it could be caused by the current code not calling HandleSyncBackgroundResults because no Xamarin project has been opened. As such this should be fixed by the refactor you just did which made the account dialog trigger the workflows if it needs them. Does that sound likely?
Comment 15 Mikayla Hutchinson [MSFT] 2013-11-13 11:02:21 UTC
Nope.
Comment 16 PJ 2013-11-19 16:38:17 UTC
This bug was targeted for a past milestone, moving to the next active non-hotfix milestone.
Comment 17 Atsushi Eno 2014-07-30 19:09:14 UTC
still reproducible.
Comment 18 Akhilesh kumar 2015-07-23 14:45:44 UTC
I have checked this issue and I am still able to reproduce this issue. 

If a trial user go to  taco.xamstage.com and purchase a Enterprise license then trial license changes to starter license instead of Enterprise.