Bug 15995 - Getting error for android sample 'Content Control'
Summary: Getting error for android sample 'Content Control'
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.10.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Peter Collins
URL:
Depends on:
Blocks:
 
Reported: 2013-11-07 09:47 UTC by narayanp
Modified: 2013-11-21 07:12 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2013-11-07 09:47:40 UTC
Steps to reproduce:
1. Open VS.
2. Open cross platform sample for android "ContentControl".
3. Click Start button.

Actual Result: It is giving error pop up which is shown in screencast: http://screencast.com/t/9uBoDtwORDPw

Expected Result: User should able to run android sample 'ContentControl'

Supplement info:
Xmarin.Android Output: http://screencast.com/t/9uBoDtwORDPw
Build Order Output: https://gist.github.com/AkhileshKumar01/7d5d1d578e749ce160bc
Trace0 Output: https://gist.github.com/AkhileshKumar01/ed1ed6d7c6ba49f2f45d

Environment details:
All Windows
VS 2013/2012/2010
X.Android 4.10.1-52

Device Info:
All Devices and Emulators

App Info:
Mobile Sample/ContenetControl

Regression Status:
NOT A REGRESSION: same behavior happening with stable X.Android 4.8.3-15
Comment 1 Peter Collins 2013-11-07 12:52:44 UTC
I could not reproduce this issue on the latest form the 4.10.1 branch, the issue your seeing is a path denied error. Please attempt to clean / update your mobile samples repo by running the following in the mobile-samples directory:
> git clean -xfd
> git reset --hard HEAD
> git pull

Please let me know if this does not resolve the issue.
Comment 2 narayanp 2013-11-08 07:01:13 UTC
Today I have checked it again after downloading fresh mobile samples on follwing builds:

All Windows
VS 2013/2012/2010
X.Android 4.10.1-57

I am still getting 'Internal Error' this is the screencast for the same: http://screencast.com/t/Mpi2ykEJ

Xamarin.Android Output: https://gist.github.com/saurabh360/3a0364fab23476d366b4
Debug Output: https://gist.github.com/saurabh360/fed5a350601263d48c50
Comment 3 Peter Collins 2013-11-08 09:30:50 UTC
As a sanity check, please manually remove all mono-android support libraries, the application (if it exists), and the mono shared runtime from the device. After cleaning your device, please clone the mobile-samples repo in the C:\ directory, and open and attempt to deploy the sample again.

Are you able to reproduce this issue in Xamarin Studio on windows?
Comment 4 narayanp 2013-11-08 10:26:24 UTC
I tried every thing as mentioned in Comment#3 but still getting same behavior. Even I have deleted my previous emulator and created new one.
Comment 5 Peter Collins 2013-11-08 11:02:03 UTC
Are you able to reproduce this issue in Xamarin Studio on windows? Or are you only seeing this issue in Visual Studio?
Comment 6 Mohit Kheterpal 2013-11-21 07:12:44 UTC
Today we have checked this issue with following builds :

VS 2013
X.Android 4.10.01073

Now we are able to deploy application on device and emulator without any error.

Hence closing this issue.