Bug 15959 - SetEGLConfigChooser doesn't have any effect
Summary: SetEGLConfigChooser doesn't have any effect
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries ()
Version: 4.10.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Radek Doulik
URL:
Depends on:
Blocks:
 
Reported: 2013-11-06 06:53 UTC by Máté Rédecsi
Modified: 2013-11-25 07:49 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Máté Rédecsi 2013-11-06 06:53:10 UTC
I'm trying to use GLSurfaceView with a custom config chooser (to enable multisampling). In the constructor of my class (derived from GLSurfaceView) I call the following:

   SetEGLContextClientVersion (2);
   SetEGLConfigChooser (new MultisampleConfigChooser ());
   SetRenderer (new OpenGLRenderer (context, this));

where MultisampleConfigChosser is my implementation of Android.Opengl.GLSurfaceView.IEGLConfigChooser and OpenGLRenderer is my renderer class (implemented GLSurfaceView.IRenderer).

ChooseConfig method of the MultisampleConfigChooser class doesn't fire at all.
Comment 1 Máté Rédecsi 2013-11-06 06:55:18 UTC
edit:
It can be reproduced with the "GLNativeES20" sample. Just add a custom configchooser into that application.
Comment 3 Radek Doulik 2013-11-20 15:38:46 UTC
Hi Máté,

how does your chooser class look like?

I tried to create an empty chooser class and put it to GLNativeES20 sample and it is reached when I run the app on device.

My empty chooser class looks like this:

using System;
using Javax.Microedition.Khronos.Egl;


namespace GLNativeES20
{
	class MyChooser : Java.Lang.Object, Android.Opengl.GLSurfaceView.IEGLConfigChooser
	{
		public EGLConfig ChooseConfig (IEGL10 egl, EGLDisplay display)
		{
			Console.WriteLine ("choose config called");
			return null;
		}
	}
}


Hopefully that will help you.

Radek
Comment 4 Prashant manu 2013-11-22 01:14:31 UTC
@Mate, Does comment#3 helps you? Are you still getting same behavior?
Comment 5 Máté Rédecsi 2013-11-22 05:18:20 UTC
Hey,

Thank you very much guys it solved my problem. I don't really know what was the problem with my chooser class, but I rebuilt it with the base of your code and it works perfectly.
Comment 6 PJ 2013-11-25 07:49:31 UTC
Thanks for responding with the positive result!