Bug 15931 - Tasky App navigation bug
Summary: Tasky App navigation bug
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 7.0.4.x
Hardware: Other Other
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-11-05 07:38 UTC by Can Aksoy
Modified: 2015-01-23 16:23 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Can Aksoy 2013-11-05 07:38:23 UTC
1. Open Tasky on simulator or on device (iPhone5)
2. Tap + icon
3. Tap < Tasky (back)
4. Tap + icon again
5. < Tasky button is not showing. (bug)

Use swipe gesture (left to right) to go home screen.
Tap + icon and you can see < Tasky back button.
This bug only happens on second attempt.

iPhone5 7.0.3
Comment 1 GouriKumari 2014-01-03 12:41:08 UTC
I couldn't reproduce this issue. I tested "Tasky" on iOS simulator 7.0 and Tasky back button appeared a second time.

Supplemental info: http://screencast.com/t/ZfgZPoXlB55D

Test Env:
Xamarin Studio
Version 4.2.2 (build 2)
Installation UUID: 473de7c6-b183-4ba3-899e-3c03c5650a88
Runtime:
	Mono 3.2.5 ((no/964e8f0)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302050000

Apple Developer Tools
Xcode 5.0.2 (3335.32)
Build 5A3005

Xamarin.iOS 7.0.4.209
Comment 2 Dmitry 2014-11-08 17:29:46 UTC
I managed to reproduce this bug using the latest Xamarin Studio (5.5.3 build 6). Simulator - iPhone 5s iOS 8.1
 
Steps: 
1. run Tasky app from Tamarin Studio in Debug mode
2. Create several tasks 
3. Stop the app
4. Run it one more time
5. Press "+" button and then don't create a new task but just press "Tasky" ("Back") button to return to tasks list
6. Press "+" again

Actual Result: "Tasky" (Back) button is absent. It's reproducible only on the second "+" pressing after app's launch.  
Expected result: "Tasky" button should be always present on Add/Edit task page
Comment 3 Udham Singh 2015-01-05 08:40:20 UTC
Thanks Dmitry for the test steps.

I have checked this issue with the help of test steps provided in comment 2 and able to reproduce this issue. Please refer the screencast : http://www.screencast.com/t/bAOrz4hHSZkT

Hence I am marking this issue as confirmed. 

Now the developer will look into this issue and please let us know if we can provide something more useful from our side.

Environment info :

=== Xamarin Studio ===

Version 5.5.4 (build 15)
Installation UUID: ce927b2a-2c07-44c5-b186-09cfdafba6dc
Runtime:
	Mono 3.10.0 ((detached/92c4884)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000031

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.4.0.47 (Enterprise Edition)
Hash: 7244769
Branch: 
Build date: 2014-12-11 14:54:30-0500

=== Build Information ===

Release ID: 505040015
Git revision: f93940a35458a18052f1a25e106e62ca970d9c40
Build date: 2014-11-19 15:32:41-05
Xamarin addins: dc23cbd91a3a0e1d326328e1229e86c942a49ec8

=== Operating System ===

Mac OS X 10.9.4
Darwin Xamarin76s-Mac-mini.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 4 Aaron Sky 2015-01-15 11:19:05 UTC
This issue is still persistent by following the steps in the description and comment 2. I have narrowed it down to a few lines of code and will be investigating it further.

Environment Info: 

=== Xamarin Studio ===

Version 5.7 (build 661)
Installation UUID: 0c38ad8a-9e2b-4b47-bc12-c639499efc27
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/aaronsky/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0.3 (API level 15)
		4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.6.0.51 (Business Edition)
Hash: dfb682f
Branch: 
Build date: 2015-01-08 13:39:32-0500

=== Xamarin.Mac ===

Version: 1.10.0.18 (Business Edition)

=== Build Information ===

Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 16:31:31-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

=== Operating System ===

Mac OS X 10.10.1
Darwin Aarons-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 5 Aaron Sky 2015-01-16 10:29:31 UTC
Alright, I have narrowed the issue down to lines 38 or 39 in controller_iPhone.cs. Oddly enough this issue is only present on the second go, and manifests regardless of whether or not you filled in information in the dialog. Furthermore, the navigation stack is affected normally and you can still swipe right to go back. I’m almost positive it’s something in Monotouch.Dialog-1.
Comment 6 Aaron Sky 2015-01-19 11:23:07 UTC
Moving this to the iOS team since this is a bug in XI and Monotouch.Dialog-1.
Comment 7 Alex Soto [MSFT] 2015-01-23 16:23:47 UTC
I have fixed the issue here

https://github.com/xamarin/mobile-samples/tree/master/Tasky

It seems that ViewWillAppear is too late to set Root and it freaks out the navigation stack, so moved the initialisation of root to Initialize() and reused the instance in ViewWillAppear https://gist.github.com/anonymous/6fbc365b273bbbb1a2ef

This fixes the back button disappearing.