Bug 15861 - "make world" hangs on "waiting for device"
Summary: "make world" hangs on "waiting for device"
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.10.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2013-10-31 17:28 UTC by Mark Probst
Modified: 2013-10-31 18:31 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
log (443.57 KB, text/plain)
2013-10-31 17:28 UTC, Mark Probst
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mark Probst 2013-10-31 17:28:16 UTC
Created attachment 5300 [details]
log

Doing "make world" in an already built monodroid (87709e8a33aea239d541a45815c4a66c3a1bb4ce) results in a hang with

error: device not found
- waiting for device -
Comment 1 Mark Probst 2013-10-31 18:31:35 UTC
"make world" is actually equivalent to doing "make reset-versions mono all install", the last of which requires a connected device.  That's not made clear in the README.  I've updated it to explain that.