Bug 15803 - If Xamarin.Android toolbar is not visible, hitting F5 crashes
Summary: If Xamarin.Android toolbar is not visible, hitting F5 crashes
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 1.10.x
Hardware: PC Windows
: Low major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-10-29 18:15 UTC by Miguel de Icaza [MSFT]
Modified: 2016-12-22 17:16 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Miguel de Icaza [MSFT] 2013-10-29 18:15:25 UTC
If you do not have Xamarin.Android toolbar shown, hitting F5 will produce this on the console:

Object reference not set to the instance of an object.
Comment 1 Ian Ceicys 2015-07-10 12:02:53 UTC
Hello Miguel, I am following up on this bug and attempting to reproduce the issue with the latest stable build of our Xamarin Visual Studio product (3.11.666) and so far I have been unable to reproduce the issue when the Xamarin.Android toolbar is not enabled. 

Here is a screencast recording of my attempt to reproduce the "Object reference not set to the instance of an object" error.

http://www.screencast.com/t/KmniSx5LJtl

At this time, I am going to update the bug to "NeedInfo" as I need additional information on the installed Xamarin version and the Xamarin logs to reproduce this error.
Comment 2 Jose Gallardo 2016-12-22 17:16:35 UTC
Marking as resolved not_reproducible on latest bits.