Bug 158 - Marshalling unsafe structures doesn't work properly anymore
Summary: Marshalling unsafe structures doesn't work properly anymore
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Interop ()
Version: unspecified
Hardware: PC Linux
: --- blocker
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-08-03 00:44 UTC by Andrius Bentkus
Modified: 2011-08-28 11:53 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
The example test case. (1.65 KB, application/zip)
2011-08-03 00:44 UTC, Andrius Bentkus
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andrius Bentkus 2011-08-03 00:44:15 UTC
Created attachment 53 [details]
The example test case.

I'm using unsafe structs in interop arguments and it just doesn't work anymore!

The code is available here:
https://github.com/txdv/monobugs/tree/master/unsafe
Comment 1 Zoltan Varga 2011-08-28 11:53:55 UTC
MS seems to allow passing structures by pointers at least in some cases, but I can't figure out when, so just enabled this again in all cases.
Fixed in HEAD/2.10 branch.