Bug 15779 - UIImage.FromBundle not working from referenced library
Summary: UIImage.FromBundle not working from referenced library
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 7.0.2.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-10-29 08:17 UTC by Carlo Wahlstedt
Modified: 2013-10-29 12:19 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Two Solutions to Test (5.98 MB, application/zip)
2013-10-29 08:17 UTC, Carlo Wahlstedt
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Carlo Wahlstedt 2013-10-29 08:17:57 UTC
Created attachment 5262 [details]
Two Solutions to Test

I have an iOS application that is loading it's views from other iOS Library projects. Some of the projects are part of the solution and they seem to function normally. However, I have another project that isn't part of the solution but is referenced to another of the iOS Library projects in the original solution. When attempting to load the view from this referenced dll (instead of project) the images do not load. I've attached two solutions as an example.

TestProjectLoad is the iOS application with 2 iOS Library projects as part of the solution. The iOS application loads a view from the IULoadingLibrary. Then the UILoadingLibrary loads a view from UILibrary. Finally, the UILibrary loads a view from the other solution (that's referenced via dll) ExternalUILib. In the final view from ExternalUILib there is an image that I would expect to load but does not. It will however load an image from any of the projects in the original iOS application solution.
Comment 1 Jeffrey Stedfast 2013-10-29 12:19:53 UTC
Add a reference to ExternalUILib.dll from the TestProjectLoad project and it'll work.