Bug 15772 - Getting 'System.ArgumentOutOfRangeException' when login with account having all used up workstations
Summary: Getting 'System.ArgumentOutOfRangeException' when login with account having a...
Status: VERIFIED DUPLICATE of bug 15770
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Activation ()
Version: 1.8.x
Hardware: PC Windows
: High critical
Target Milestone: 1.8.x (VS2013)
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-10-29 04:59 UTC by narayanp
Modified: 2013-11-19 05:13 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 15770

Description narayanp 2013-10-29 04:59:46 UTC
Steps to reproduce:
Condition: User should have license and all workstation are used up.
User has never activated on this machine before using this account.

1. Open VS
2. Create iOS application
2. Login window appears 
3. Log in with account which having trial account which is used up.

Actual Result: Getting 'System.ArgumentOutOfRangeException' .

Expected Result: User should informed about no workstation available.

Supplement info : 
Error Log : https://gist.github.com/AkhileshKumar01/0dcdad605372d1ec8f8e
Trace0 Logs :https://gist.github.com/AkhileshKumar01/856e6abd35d9eecfa437
screencast :http://screencast.com/t/iwkkinjj

Environment info :
All windows
XS 4.1.7 (build 1551)
VS 2013 / 2012
MTVS 1.8.205
Comment 1 Mikayla Hutchinson [MSFT] 2013-10-29 14:34:20 UTC

*** This bug has been marked as a duplicate of bug 15770 ***
Comment 2 Atin 2013-11-19 05:13:55 UTC
Today, we have checked this issue with following builds:
MTVS 1.8.365
VS 2013/12/10
Windows 7

Now, if user Logged in with account having all used up workstations it gives the pop that "Too many machines are using your Xamarin subscription" without any error.

Hence marking this as Verified