Bug 15749 - Solutions with multiple deployable applications only deploy the current app
Summary: Solutions with multiple deployable applications only deploy the current app
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 3.0
Hardware: PC Windows
: Normal normal
Target Milestone: 4.3.0 (C9)
Assignee: vsx
URL:
Depends on:
Blocks:
 
Reported: 2013-10-28 12:24 UTC by Mike Hartman
Modified: 2016-12-30 09:50 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mike Hartman 2013-10-28 12:24:20 UTC
When a solution has multiple applications in the same solution, even though multiple applications are set for deployment in Configuration Manager, only the application set as the "Startup Project" is deployed to the device when starting a debug session.  This occurs even though multiple applications have changed and get recompiled.

It works correctly when choosing "Deploy Solution" to Target.
Comment 1 narayanp 2013-11-22 01:52:06 UTC
I have checked this issue with following builds:

All Windows
VS 2013/2012/2010
MTVS 1.8.365
X.Android 4.10.1

I am also able to reproduce this issue. To reproduce this issue I have created an Android project and then added another android project in same solution. Then click on start button, It deploy and launch only start-up project. While If I right click on Solution->Deploy Solution. in that case it deployed both project on device.
Comment 2 Enzo Heredia 2015-06-30 14:35:33 UTC
still reproducible build 4.0.0.307
Comment 3 Rajneesh Kumar 2015-07-15 06:20:10 UTC
I have checked this issue with the latest stable build XVS 3.11.666 and observed that this issue still exist with this build. I observed that when I right click on Solution->Deploy Solution, in this case it deployed both project on device.

Screencast: http://www.screencast.com/t/VTVAwiCOA0Q6

Thanks..!

Environment Info:

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938
Installed Version: Professional
Xamarin   3.11.666.0 (ebae43a)
Visual Studio extension to enable development for Xamarin.iOS and
Xamarin.Android.
Xamarin.Android   5.1.4.16 (5f55a9ef61c11b6ce0890bc91e4c71b1b92be214)
Visual Studio plugin to enable development for Xamarin.Android.
Xamarin.iOS   8.10.2.0 (67b390d0d1bd741582cf7b7fd3ffea08583a3f83)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 5 Jose Gallardo 2016-12-27 22:09:13 UTC
This was fixed for some scenarios in Cycle9 (XVS 4.3 currently on the alpha channel).

We're now supporting multi-process debugging, with some caveats:

1. We don't support two iOS apps running at the same time.
2. The user should take care of the solution configurations (using the configuration Manager), and ensure all the required projects are build and deployed if needed for the right platform/configuration.

Marking the bug as resolved.

Thanks!
Comment 6 Akhilesh kumar 2016-12-30 09:50:50 UTC
Now we are supporting multi-process debugging in Cycle 9 builds with some limitation and caveats mentioned in Comment 5.

I am successfully able to run/deploy multiple android application with in VS.

So I am closing this issue.


Microsoft Visual Studio Enterprise 2015
Version 14.0.25425.01 Update 3
Microsoft .NET Framework
Version 4.6.01055

Xamarin   4.3.0.514 (fe08ff6)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin Inspector Support   1.0.0.0 (1f3067d)
Adds support for inspecting Xamarin and WPF apps.

Xamarin.Android   7.1.0.16 (4ce2ebd)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.4.0.65 (0366d84)
Visual Studio extension to enable development for Xamarin.iOS.