Bug 1574 - User able to select other Active configuration option while build application is in process.
Summary: User able to select other Active configuration option while build application...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 1576 ()
Depends on:
Blocks:
 
Reported: 2011-10-19 09:27 UTC by narayanp
Modified: 2013-05-29 14:09 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2011-10-19 09:27:48 UTC
Step to Reproduce:

1. Launch the Mono Develop and create a application.
2. Select "debug/iPhone Simulator" from Active configuration drop box.
3. Click on Build<<Build All to build the application.
3. Click on Active Configuration box and try to select any other option.

Actual result:
User able to select other Active configuration option while build application is in progress.

Expected Result:
User should not able to select other Active configuration option while build application is in progress.

Environment:
Mono Develop - 2.8.1
MonoTouch- 5.0
Mono Framework - 2.6
Comment 1 Sebastien Pouliot 2011-10-19 09:31:56 UTC
-> monodevelop
Comment 2 Alan McGovern 2011-11-15 14:44:32 UTC
Makes sense and this should be fixed
Comment 3 Alan McGovern 2011-11-15 14:48:49 UTC
*** Bug 1576 has been marked as a duplicate of this bug. ***
Comment 4 Alan McGovern 2011-11-15 14:49:11 UTC
This should also be disabled while the application is running.
Comment 5 Akhilesh kumar 2013-05-29 14:08:58 UTC
Today we have checked this issue on following builds :

XS 4.0.8(build 2)
MT 6.2.6.6
Mono 2.10.12

Now Ww are not able to select other Active configuration option while build application is in progress.


Hence changing its status to verified.