Bug 1571 - Error occurs in Debugging application from path Run<<Debug Application.
Summary: Error occurs in Debugging application from path Run<<Debug Application.
Status: CLOSED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 2.8
Hardware: Macintosh Mac OS
: Low major
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2011-10-19 09:19 UTC by narayanp
Modified: 2011-12-22 18:12 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot (156.93 KB, image/png)
2011-10-19 09:19 UTC, narayanp
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description narayanp 2011-10-19 09:19:11 UTC
Created attachment 720 [details]
Screenshot

Step to Reproduce:

1. Launch the Mono Develop and create a application.
2. Select "Debug/iPhoneSimulator" from Active configuration drop box.
3. Go to Run<<Debug Application. Application to Debug Pop window opens up.
4. select any solution and click on "Open" button.

Actual result:
Error window opens up with message "Error while execution command: Debug Application".

Expected Result:
Error window should not open and user should able to debug the application.

Environment:
Mono Develop - 2.8.1
MonoTouch- 5.0
Mono Framework - 2.6

Test Data:
Please refer to screen shot "Debug app error"
Comment 1 Sebastien Pouliot 2011-10-19 11:53:49 UTC
-> monodevelop
Comment 2 Mikayla Hutchinson [MSFT] 2011-10-19 17:16:05 UTC
When you get errors like this, could you copy/paste the stacktrace into the bug report from the error dialog?
Comment 3 Chris Hardy [MSFT] 2011-11-10 13:16:47 UTC
Stack trace is: https://gist.github.com/97c7b6478e93b547b15a

System.InvalidOperationException: Unsupported command: MonoDevelop.Core.Execution.NativeExecutionCommand
  at MonoDevelop.Debugger.DebuggingService.InternalRun (MonoDevelop.Core.Execution.ExecutionCommand cmd, MonoDevelop.Debugger.DebuggerEngine factory, IConsole c) [0x000fc] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.Debugger/MonoDevelop.Debugger/DebuggingService.cs:511 
  at MonoDevelop.Debugger.DebugExecutionHandler.Execute (MonoDevelop.Core.Execution.ExecutionCommand command, IConsole console) [0x00000] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.Debugger/MonoDevelop.Debugger/DebugExecutionHandlerFactory.cs:70 
  at MonoDevelop.Debugger.DebuggingService.Run (System.String file, IConsole console) [0x00013] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.Debugger/MonoDevelop.Debugger/DebuggingService.cs:415 
  at MonoDevelop.Debugger.Extensions.DebugApplication (MonoDevelop.Ide.ProjectOperations opers, System.String executableFile) [0x0005c] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.Debugger/MonoDevelop.Debugger/Extensions.cs:86 
  at MonoDevelop.Debugger.DebugApplicationHandler.Run () [0x0002d] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.Debugger/MonoDevelop.Debugger/DebugCommands.cs:239 
  at MonoDevelop.Components.Commands.CommandHandler.Run (System.Object dataItem) [0x00000] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandHandler.cs:61 
  at MonoDevelop.Components.Commands.CommandHandler.InternalRun (System.Object dataItem) [0x00000] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandHandler.cs:42 
  at MonoDevelop.Components.Commands.CommandManager.DefaultDispatchCommand (MonoDevelop.Components.Commands.ActionCommand cmd, MonoDevelop.Components.Commands.CommandInfo info, System.Object dataItem, System.Object target, CommandSource source) [0x00076] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandManager.cs:649 
  at MonoDevelop.Components.Commands.CommandManager.DispatchCommand (System.Object commandId, System.Object dataItem, System.Object initialTarget, CommandSource source) [0x002d1] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandManager.cs:619
Comment 4 Chris Hardy [MSFT] 2011-11-10 13:17:48 UTC
Additionally, I have never used this menu item before and I have no idea what it's meant to do... Should it just be removed?
Comment 5 Joseph Hill 2011-11-11 17:38:18 UTC
I agree with Chris. We should remove this menu option.
Comment 6 Lluis Sanchez 2011-11-16 08:55:57 UTC
The command allows debugging an executable for which you don't have a project. I don't see why we should remove it.
Comment 7 Jeffrey Stedfast 2011-12-08 16:30:15 UTC
fixed
Comment 8 Atin 2011-12-09 02:52:11 UTC
this issue has been fixed and validated with MonoDevelop 2.9.1. Now this has been closed from our side.