Bug 157 - MD fails to load assemblies that are symlinked to another file e.g. those in the GAC
Summary: MD fails to load assemblies that are symlinked to another file e.g. those in ...
Status: REOPENED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: Trunk
Hardware: PC Linux
: Low minor
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-08-02 23:11 UTC by Atsushi Eno
Modified: 2016-05-26 21:51 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
example sshot (27.05 KB, image/png)
2011-08-02 23:11 UTC, Atsushi Eno
Details
proposed fix (UnixSymbolicLinkInfo.ContentsPath could be relative, which is problematic here.) (597 bytes, patch)
2011-08-03 02:43 UTC, Atsushi Eno
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 157 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
REOPENED

Description Atsushi Eno 2011-08-02 23:11:11 UTC
Created attachment 52 [details]
example sshot

On Ubuntu I tried to open webkit-sharp.dll from $(PREFIX)/mono/webkit-sharp/webkit-sharp.dll. It is our typical installation that is a symlink to the file in the GAC.
monodevelop somehow fails to resolve the symlink and reports an attempt to load from the wrong path (attached the error dialog).

How to repro (if you don't have any assemblies in the GAC or want to try standalone case):

- create a class lib file:

public class Test
{
	public void Foo () { }
}

- $ mcs test.cs -t:library
- $ mkdir indepth
- $ cd indepth
- $ ln -s ../test.dll .
- Open MD and open indepth/test.dll (i.e. symlink)
Comment 1 Atsushi Eno 2011-08-03 02:43:27 UTC
Created attachment 54 [details]
proposed fix (UnixSymbolicLinkInfo.ContentsPath could be relative, which is problematic here.)
Comment 2 Mikayla Hutchinson [MSFT] 2011-11-15 16:18:49 UTC
This could also affect symlinked solutions.
Comment 3 Marius Ungureanu 2013-11-23 09:20:38 UTC
What is the status of this?
Comment 4 xamarin-release-manager 2016-05-26 21:22:35 UTC
Fixed in version 6.1.0.4366 (android-component-debugging)

Author: Robert Jeppesen
Commit: fccd41feee51eb0da315a6302cd2a17d97976bbe (mono/monodevelop)
Comment 5 Marius Ungureanu 2016-05-26 21:51:03 UTC
Reopening.