Bug 15651 - [Xcode 5.0.1] "CAQuartzComposition" application gets crash with Mono Runtime.
Summary: [Xcode 5.0.1] "CAQuartzComposition" application gets crash with Mono Runtime.
Status: RESOLVED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.6.19
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2013-10-24 10:10 UTC by Saurabh
Modified: 2014-12-03 16:51 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Saurabh 2013-10-24 10:10:36 UTC
Step to reproduce:
1. Open CAQuartzComposition application in XS
2. Set configuration : (Include Mono Runtime | Link Framework SDKs Only | Sgen) 
2. Debug the application

Actual result:
As soon as application launches, it gets crash. 

Expected result:
Application should not crash and should launch successfully.

Screencast: http://www.screencast.com/t/MDtsMirMzWKG
Application output: https://gist.github.com/AkhileshKumar01/60d48c136632095aff5c
Problem details: https://gist.github.com/AkhileshKumar01/cb7c54e74dcc52713440

Environment info:
Xamarin Studio
Version 4.0.14 (build 5)
Installation UUID: b1fc3b76-cf00-405e-a0a1-3839ac11fe6d
Runtime:
	Mono 3.2.4 ((no/f163333)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302040000

Apple Developer Tools
Xcode 5.0.1 (3335.6)
Build 5A2034a

Xamarin.iOS
Version: 7.0.4.86 (Business Edition)
Hash: 47ed9fa
Branch: 
Build date: 2013-22-10 15:08:22-0400

Xamarin.Android
Version: 4.10.1 (Business Edition)
Android SDK: /Users/apple/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

Xamarin.Mac
Xamarin.Mac: 1.6.25

Build Information
Release ID: 400140005
Git revision: 8ecd354300afde1daf38261b733335a5a8b4cbf1
Build date: 2013-10-21 19:52:19+0000
Xamarin addins: fac7059576f0548a7b1a17eed92e5d280e3ae5bf

Operating System
Mac OS X 10.9.0
Darwin Apples-iMac.local 13.0.0 Darwin Kernel Version 13.0.0
    Thu Sep 19 22:22:27 PDT 2013
    root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64
Comment 1 Saurabh 2013-10-24 10:21:59 UTC
Note: This issue exist with only Xcode 5.0.1 (3335.6), Build 5A2034a.

Regression status: This issue also exists with Stable builds XS 4.0.13 (build 38) and Xamarin.Mac: 1.6.19
Comment 2 Chris Hamons 2014-12-03 16:51:28 UTC
This appears fixed in a non-ancient version of Xamarin.Mac.