Bug 15615 - If there is no license on disk then we are seeing X.iOS version as 1.2.3.4 on Xamarin.iOS build host window
Summary: If there is no license on disk then we are seeing X.iOS version as 1.2.3.4 on...
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 7.0.4.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: 7.0.4 (Activation)
Assignee: Jérémie Laval
URL:
Depends on:
Blocks:
 
Reported: 2013-10-23 08:45 UTC by Prashant manu
Modified: 2013-10-24 10:40 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Prashant manu 2013-10-23 08:45:05 UTC
Steps to reproduce:
[Condition: no license should be exists on disk]
1. Open Xamarin.iOS build host application.

Actual Result: Xamarin.iOS build host application displaying version as 1.2.3.4 when no license on disk, When user activate with Business or priority then correct license displayed on Xamarin.iOS build host window.

Note: In case of Indie license also we are not getting correct version.

Expected Result: Correct license should displayed on Xamarin.iOS build host application when no license is on Xamarin.iOS app.

Supplement info:
http://screencast.com/t/t6PprIeVGp4


Environment details:
All Mac
X.iOS 7.0.4.86
Mono 3.2.4
Comment 1 Jérémie Laval 2013-10-23 12:18:45 UTC
Fixed in both master and 7.0.4

Thanks!
Comment 2 narayanp 2013-10-24 10:40:28 UTC
Today I have checked this issue with following builds:

All Mac
X.S 4.1.7(build 1532)
X.iOS 7.0.4.118

Now we are getting correct version of MT on Xamarin.iOS build host window when no license on disk. This is the screencast for the same: http://screencast.com/t/N3o76rxxnEg

Changing the status to Verified.