Bug 15485 - Finder does not open on build host when user click on 'Show IPA File in Finder' on VS
Summary: Finder does not open on build host when user click on 'Show IPA File in Finde...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.6.x
Hardware: PC Windows
: Normal normal
Target Milestone: 1.6.x (connection)
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-10-18 10:42 UTC by Mohit Kheterpal
Modified: 2013-10-21 07:59 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mohit Kheterpal 2013-10-18 10:42:04 UTC
Steps to reproduce this issue.
1. Open VS 2012/2013
2. Create or open iOS application.
3. Open project option.
4. Select iOS IPA option and check 'Build Ad-hoc/enterprise package(IPA).
5. Save project.
6. Deploy application on device
7. Click 'Show IPA file in Finder'.

Actual result: After clicking on 'Show IPA file in Finder', Finder does not open on mac server which is connected to VS.

Expected result: Finder should open on Mac server after clicking on 'Show IPA file in Finder'.

Note :I have checked it on Build host, IPA file for the same application is exist on following path :
Users/apple/Library/Caches/Xamarin/mtbs/builds/HelloWorld_App67/a8ba5c4a-c826-488b-a602-6bb9db59d275/output

Regression Status : Same behavior is happening with latest stable MTVS 1.3.250 and MT 7.0.2.7. But this was fixed in Bug 11469.

Environment details:
VS 2012/2010
MTVS 1.6.131
Xamarin.iOS 7.0.3.206

Mac Server
Lion 10.7.4
Maverics : 10.9
Comment 1 PJ 2013-10-18 11:04:13 UTC
We might have to live with this bug for 1.6, but I'd like Dominique to see it before we move to that milestone.
Comment 2 Dominique Louis 2013-10-18 14:02:47 UTC
I'm looking into this issue.
Comment 3 Dominique Louis 2013-10-18 17:15:46 UTC
Fix should be part of this build - https://wrench.internalx.com/Wrench/ViewLane.aspx?lane_id=717&host_id=69&revision_id=210895 when it is ready.
Comment 4 Nischal 2013-10-21 07:59:11 UTC
Today I have checked this issue with following builds:

All Windows
iOS for VS 1.8.25
X.iOS 7.0.4.84
VS 2013/2012/2010

Now IPA file opens in Finder after clicking on 'Show IPA file in Finder' .

Changing the status to Verified.