Bug 15432 - When build host server's network is OFF then VS does not prompts to connect with another Build host
Summary: When build host server's network is OFF then VS does not prompts to connect w...
Status: VERIFIED DUPLICATE of bug 15421
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.6.x
Hardware: PC Windows
: --- normal
Target Milestone: 1.8.x (VS2013)
Assignee: Dominique Louis
URL:
: 15433 ()
Depends on:
Blocks:
 
Reported: 2013-10-16 09:25 UTC by Akhilesh kumar
Modified: 2015-01-05 11:20 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 15421

Description Akhilesh kumar 2013-10-16 09:25:16 UTC
Steps to reproduce :
1. Open VS
2. Connect and pair VS to build host.
3. Observe that build host is connecte and paired with VS
4. Make network OFF on build host.
5. create or open application in VS.
6. Click on Start button.

Actual Result: It does not prompt us to connect to another build host.

Expected Result : VS should prompts user to connect to different build host available in network if connected build host is has no network. 

Environment info :
VS 2012 / 2013/ 2010
MTVS 1.6.95
MT 7.0.3.193
Comment 1 Dominique Louis 2013-10-16 10:14:17 UTC
As per #15421 Auto popping up was discussed during out calls.
When no build server is detected a the error message should give better instructions on what should be done to find a working build server. Please check the comments on #15421 for further info. Moving this to 1.8 until we've discussed it next week.
Comment 2 Dominique Louis 2013-10-16 10:15:45 UTC
*** Bug 15433 has been marked as a duplicate of this bug. ***
Comment 3 PJ 2013-10-16 17:02:10 UTC
I'm going to mark this as a duplicate of bug 15421, they're essentially the same issue and we want to record the information about the expected behavior in a single place.

*** This bug has been marked as a duplicate of bug 15421 ***
Comment 4 Mohit Kheterpal 2013-11-18 07:33:10 UTC
Today I have checked this issue with following builds:

All Windows
VS 2013 / 2012
iOS for VS 1.8.365
X.iOS 7.0.4.175

We observed that when we close the Xamarin.iOS build host from connected
machine and build the application it does not prompt us to connect to another
build host. If we click on start button it display an error 'Connection to
Xamarin.iOS Build Host failed. Double click here to select a server'. After
clicking on this error, 'Connect to Xamarin.iOS Build Host' appears. This is
the screencast for the same: http://screencast.com/t/h16qd5S9

Changing the status to Verified.