Bug 15430 - IPA package not named correctly
Summary: IPA package not named correctly
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 4.0.13
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: 4.0.14
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-10-16 07:52 UTC by Chris
Modified: 2013-10-23 05:17 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Chris 2013-10-16 07:52:30 UTC
Description of Problem:

When building a "release" ipa, the name of the file is no longer reflecting the 'Build' info in the info.plist file if you update it without closing and re-opening the project.

Steps to reproduce the problem:

1. Open project and update 'Build' number in info.plist eg from 1.0.0.1 to 1.0.0.2
2. Build release


Actual Results:
ipa filename results in 'MyProject_1.0.0.1.ipa'


Expected Results:
ipa filename of 'MyProject_1.0.0.2.ipa'

How often does this happen? 
Everytime since I installed the last updates a few days ago. 

Additional Information:
Currently running lastest Xamarin Studio 4.13 build 38
Comment 1 Jeffrey Stedfast 2013-10-18 13:42:09 UTC
Fixed in git master (I'll see about backporting to the next major release)
Comment 2 narayanp 2013-10-23 05:17:38 UTC
Today I have checked this issue with following builds:

X.S 4.1.7(build 1530)
Mono 3.2.4
X.iOS 7.0.4.86

Now we are getting updated ipa name as per build number. This is the screencast for the same: http://screencast.com/t/4UzuYpp6w

Changing the status to Verified.