Bug 15400 - Error when uploading application to iOS device - could not upload it
Summary: Error when uploading application to iOS device - could not upload it
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 6.4.4
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-10-15 09:28 UTC by Rebex.NET
Modified: 2016-05-24 20:22 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Rebex.NET 2013-10-15 09:28:08 UTC
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
MonoTouch.MobileDevice.MobileDeviceException: AMDeviceConnect returned: 0xe8000065 (kAMDMuxConnectError)
at MonoTouch.Installation.Device.Connect () <0x0007b>
at MonoTouch.Installation.Installer/<ExecuteWithSession>c__AnonStorey17.<>m__1E (object,System.EventArgs) <0x00017>
at MonoTouch.Installation.Device.NotificationCallback (MonoTouch.MobileDevice.am_device_notification_callback_info&) <0x00075>
at (wrapper native-to-managed) MonoTouch.Installation.Device.NotificationCallback (MonoTouch.MobileDevice.am_device_notification_callback_info&) <0x0005b>
at (wrapper managed-to-native) MonoMac.CoreFoundation.CFRunLoop.CFRunLoopRun () <0x00003>
at MonoMac.CoreFoundation.CFRunLoop.Run () <0x0000b>
at MonoTouch.Installation.Installer.ExecuteWithSession (string,MonoTouch.Installation.Installer/Executor) <0x000d7>
at MonoTouch.Installation.Installer.InstallApplicationWithoutSymbols (string,string) <0x00067>
at MonoTouch.Installation.Installer.InstallApplication (string,string,bool) <0x0002f>
at MTouch.Main2 (string[]) <0x02773>
at MTouch.Main (string[]) <0x00017>

The application was terminated by a signal: SIGHUP
Comment 1 Sebastien Pouliot 2013-10-15 13:12:42 UTC
Is this something that happens every time (or just once) ?

Also can you tell us which:

* kind of device(s) and iOS version were used ?

* the version of the software you're using ?

The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).
Comment 2 Rebex.NET 2013-10-15 13:49:30 UTC
Hello Sebastien,

it happens quite often after an app has been deleted and I want to reupload another app with the same provisioning profile. The device is iPad running iOS 6.1.3.

The only thing that helps is disconnect and reconnect the iPad (USB cable). Sometimes restart of Xamarin Studio is also needed.

Here is the version of Xamarin components:


Xamarin Studio
Version 4.0.8 (build 2)
Installation UUID: 8fd3a4be-6abb-43d5-b84a-0f92b53dcb5a
Runtime:
	Mono 3.2.0 ((no/7c7fcc7)
	GTK 2.24.20
	GTK# (2.12.0.0)
	Package version: 302000000

Xamarin.Android
Not Installed

Apple Developer Tools
Xcode 4.6.3 (2068)
Build 4H1503

Xamarin.iOS
Version: 6.4.5.0 (Business Edition)
Hash: 1336a36
Branch: 
Build date: 2013-10-09 11:14:45-0400

Xamarin.Mac
Xamarin.Mac: Not Installed

Build Information
Release ID: 400080002
Git revision: 0a09117dec1aed78c735ac46f7a50ae7d12f7a7a
Build date: 2013-05-16 19:36:29+0000
Xamarin addins: 78d0437c3f92ae13042f81e5fd9487e2c28d5fbc

Operating System
Mac OS X 10.8.3
Darwin macmini 12.3.0 Darwin Kernel Version 12.3.0
    Sun Jan  6 22:37:10 PST 2013
    root:xnu-2050.22.13~1/RELEASE_X86_64 x86_64
Comment 3 Sebastien Pouliot 2016-05-24 20:22:59 UTC
There were not any duplicate for this bug (at similar times) so it looks like it might have been device-dependent (e.g. bad cable or requiring the device to be rebooted).

If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!