Bug 15313 - If I unfocus the pairing dialog during solution load, the modal 'Loading solution projects' dialog prevents any further actions
Summary: If I unfocus the pairing dialog during solution load, the modal 'Loading solu...
Status: VERIFIED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.8.x
Hardware: PC Mac OS
: --- critical
Target Milestone: 1.8.x (VS2013)
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-10-09 18:15 UTC by PJ
Modified: 2015-01-05 11:20 UTC (History)
12 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED NOT_REPRODUCIBLE

Description PJ 2013-10-09 18:15:30 UTC
Steps to reproduce:

1) Be unpaired
2) Open a solution
3) See the pairing dialog appear
4) After a few seconds, the 'Loading solution projects' dialog appears behind the pairing dialog
5) Click on the 'Loading solution projects' dialog
6) Attempt do do anything else at that point

Expected:

The window is seen in the task bar so I can re-focus it, or otherwise stays on top till resolved

Actual:

http://screencast.com/t/WSpILczscQdO
I have to end the process or alt tab.

We should avoid situations where people feel like they should kill devenv from the task manager. The window should just be a normal window (selectable from the task bar), modal, or should not prevent the solution load from finishing (so at the very least I can minimize VS and see it).



MTVS 1.6.71
VS2012
Win7x64
Comment 1 dean.ellis 2013-10-10 09:23:53 UTC
PJ 

Fixed this in master and cherry-picked

XamarinVS/master/8f5256db06
Comment 2 Alan McGovern 2013-10-26 13:04:25 UTC
Note to me: I rewrote some of this code for 1.8 so I want to double check I have not regressed this fix.
Comment 3 dean.ellis 2013-10-30 12:54:34 UTC
The pairing dialog doesn't appear while the progress bar is showing, so its not possible to switch focus. Doesn't look like this regressed.
Comment 4 GouriKumari 2013-11-04 17:40:47 UTC
Hi Oleg,
Could you verify this bug and add a testcase to QA Automation test suite.

Best,
Gouri
Comment 5 Oleg Demchenko 2013-11-04 19:48:54 UTC
As Dean told,  pairing dialog doesn't appear while the progress bar is showing. Works fine for me

Here is actual: 
http://screencast.com/t/hwh3VQjEu

MTVS 1.8.277.0
VS2012
Win7x64
Comment 6 Alan McGovern 2013-11-04 21:57:01 UTC
There's no need to keep reassigning this if it's closed. It was only re-opened for me to double check, i didn't mean for it to propagate through so many people.
Comment 7 Atin 2013-11-28 07:34:38 UTC
Today, we have checked this issue with:

Windows 7
VS 2012
MTVS 1.10.12
MT 7.0.5.0

Now I have observed that when we create or open solution the it prompts us to connect to build host. When we select any build host then it prompts us to enter PIN. After entering PIN, A loading window appear and we are unable to click on that because is goes away very fast and project loads successfully. This is the screencast for the same: Screencast: http://screencast.com/t/Df3kflF4fVDD
 
Hence marking this as Verified