Bug 15259 - 'Refresh build server info' button get disable after clicking on it.
Summary: 'Refresh build server info' button get disable after clicking on it.
Status: VERIFIED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 0.x Insider Preview
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-10-08 02:35 UTC by Prashant manu
Modified: 2015-01-05 11:21 UTC (History)
11 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description Prashant manu 2013-10-08 02:35:33 UTC
Steps to reproduce:
1. Open VS.
2. Create or open any iOS application.
3. Connect to build host.
4. Click on Refresh build server info' button.

Actual Result: When user click on 'Refresh build server info' it gets disable and it gets enable when user click on 'Connection Status'.

Expected Result: 'Refresh build server info' button should not get disable after clicking on it.

Supplement info:
http://screencast.com/t/UVP73VUw
Mac Server Log: https://gist.github.com/AkhileshKumar01/15fb9e330a2b1646ded9

Environment details:
All Windows
VS 2010/2012/2013
iOS for VS 1.6.57
X.iOS 7.0.3.45
Comment 1 Timothy Risi 2013-10-08 12:46:34 UTC
How long are you waiting after pressing the button?  From what I can tell the button disables while it's working (getting the info from the server), then becomes enabled again after it's done.  Sometimes it renables within a few seconds for me, others it takes a good 30+ seconds.
Comment 2 narayanp 2013-10-09 10:47:51 UTC
Today I have checked this issue with following builds:

All Windows
VS 2013/2012/2010
iOS for VS 1.6.71
X.iOS 7.0.2.40

On Windows 8.1 this is taking 30s to 1 minute while on other windows it is taking minimum 4-5 minutes
Comment 3 dean.ellis 2013-10-10 06:51:54 UTC
Tim is correct, the button is disabled while the process is running, since there is no point in running the same thing over and over. 

Obviously the amount of time it takes to complete will vary because its talking to the Mac host to get information. 

This is expected behaviour.
Comment 4 Saurabh 2013-11-19 05:19:48 UTC
As per comment 3 marking this as Verified invalid