Bug 15172 - Sample application Background Execution is giving error while running through MTVS.
Summary: Sample application Background Execution is giving error while running through...
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 7.0.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: GouriKumari
URL:
Depends on:
Blocks:
 
Reported: 2013-10-03 10:56 UTC by Akhilesh kumar
Modified: 2013-10-04 03:41 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Akhilesh kumar 2013-10-03 10:56:20 UTC
Steps to reproduce:
1.Open Background execution sample in VS 2010/2012.
2.Run the application.

Actual Result:Getting "error : Remote build step failed" while running background execution sample.

Expected Result:Application should build and deploy successfully on Device/Simulator.

supplement Info:
Debug build output:https://gist.github.com/AkhileshKumar01/6de19df15582048d7936
Mac server log:https://gist.github.com/AkhileshKumar01/48d333cc7d5ece8d2e17

Environment Details:
VS 2010/2012
MTVS 1.3.250
MT 7.0.2.6
Xcode 4.5/4.6/5
iPhone 4-6.1
iPhone 4s-7.0
Sample details: monotouch-samples-master-93d01b3f854f663236ac5db44e92da6e808e209c.zip

Regression Status:This issue also exist with stable MT 7.0.0.11 with commit monotouch-samples-master-93d01b3f854f663236ac5db44e92da6e808e209c 

Note:This issue only exist with monotouch-samples-master-93d01b3f854f663236ac5db44e92da6e808e209c while with previous commit monotouch-samples-master a09a2d495883e666c993ad2a4d0a61f4ed16e6c9 it is working fine with both MT 7.0.2.6 and 7.0.0.11.
Comment 1 PJ 2013-10-03 12:32:08 UTC
Hrm.

This result doesn't completely make sense. There haven't been any changes to the Background Execution sample between the commits you list.

Here's the github page showing the latest changes for each file/folder: http://screencast.com/t/WOSTSSPS

The last change was 21 days ago.

a09a2d495883e666c993ad2a4d0a61f4ed16e6c9 is from 9 days ago.


Is there any chance you're not testing on the same device or environment? 

Perhaps there's an issue with the MTVS build server caching as well. Can you check to see if there's a cached build in ~/Library/Caches/Xamarin/mtbs/builds/?
Comment 2 Sebastien Pouliot 2013-10-03 14:12:53 UTC
The log suggest that the sample .xib were saved with a recent Xcode and then built with an older version

https://gist.github.com/AkhileshKumar01/48d333cc7d5ece8d2e17#file-gistfile1-txt-L352

> Xcode 4.5/4.6/5

^ not helpful


note: IMO customers should be able to use an older (than the latest) Xcode to build samples (at least those not specific to iOS7)
Comment 3 PJ 2013-10-03 16:01:12 UTC
Fixed in monotouch-samples/d3a0507

We'll have to make a decision about how to deal with the nav bar issue once and for all. Do we update all xibs to be compatible with 4.6, or do we try to adjust the layout and keep compatibility with Xcode 4.4?

From Xcode5, we can make it compatible with Xcode 4.6. This gives us the iOS 6 look and feel even on an iOS7 device, but the xib continues to be unbuildable from Xcodes < 4.6.

So then I changed the compatibility  to Xcode 4.6, opened it in 4.6, and then changed it to 4.4. At that point, the nav bar layout issue returned on iOS7 devices.

To fix this for all iOS versions and maintain compatibility with Xcode 4.4, I took the simple approach. I moved the button down.


For this particular sample, it's not too big of a deal, but I'd be interested to know what your thoughts are here Sebastien. Do we want to have our sample apps work on Xcode 4.4, look good on iOS7, or some mixture of both?

This has implications for some of the other fixes made for iOS7 compatibility.

Cc'ing Nina as well, she might have thoughts on it from the docs side.
Comment 5 narayanp 2013-10-04 03:41:46 UTC
Today I have checked this issue with latest monotouch sample-1bf501bb67021c9b3acdf043b19307e59e352a1f

And application working fine on all devices and Xcodes

All Windows
VS 2012/2010
iOS for VS 1.3.250
X.iOS 7.0.2.6

Changing the status to Verified.