Bug 1510 - MonoDevelop update proposed, but can't update
Summary: MonoDevelop update proposed, but can't update
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Updater ()
Version: 2.8
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2011-10-15 08:03 UTC by Thomas Goldstein
Modified: 2011-12-14 07:10 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Thomas Goldstein 2011-10-15 08:03:12 UTC
I have MonoDevelop 2.8 on Windows.
When I open it, I get this window: "The following updates have been downloaded and are ready to install: MonoDevelop".
I click the "Update and Restart" button, and I get an error. Error message box title is: "WindowsUpdater.exe - .NET Framework Initialization Error", content is: "Unable to find a version of the runtime to run this application.".

Checking the MonoDevelop, 2.8 seems to be the latest version right now, so maybe this update shouldn't even be proposed.
Comment 1 Alan McGovern 2011-11-15 12:18:03 UTC
This sounds like the WindowsUpdater.exe file is built against a version of the .NET framework which you do not have installed. We need to check what FX version MonoDevelop is built against and also what FX version the updater is built against. If one works, both should.
Comment 2 Thomas Goldstein 2011-11-15 14:15:12 UTC
Alright. For the record, I've got .NET 2.0, 3.5 and 4.0. I had 1.1 at some point, but removed it a while ago. So I guess this means the updater requires 1.1.
Comment 3 Alan McGovern 2011-11-16 15:36:57 UTC
From the information I've gathered so far, the dialog box displaying the initialisation error message should also give additional information such as the version of the .NET framework which is required for the application to run. Would you be able to launch the app and attach that information to the bug report? 

It looks like we're targeting .NET 3.5 which is potentially why you are seeing this problem. We should probably target .NET 4.0.
Comment 4 Thomas Goldstein 2011-11-16 15:44:52 UTC
There was no such info. I retyped everything that was in the message.

If you Google Image ".NET Framework Initialization Error", you'll see the version info is not always included.
Comment 5 Alan McGovern 2011-11-16 16:40:12 UTC
That's  no problem. I just wanted to make sure that you didn't accidentally leave some information out. I'm getting a VM set up to try and reproduce this issue and figure out a fix.
Comment 6 Alan McGovern 2011-12-14 07:10:19 UTC
This problem has been fixed, the windows updater is now being built against the .NET 4.0 framework (the same as everything else) so it should work fine with 2.8.5 and higher.