Bug 1507 - The updater states that it is cancelling the update (obviously it does not cancel it, it is installing it)
Summary: The updater states that it is cancelling the update (obviously it does not ca...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Updater ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Alan McGovern
URL:
: 2539 2682 ()
Depends on:
Blocks:
 
Reported: 2011-10-15 05:05 UTC by Attila Tamás Zimler
Modified: 2012-01-19 20:34 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of the bug. (3.63 MB, image/png)
2011-10-15 05:05 UTC, Attila Tamás Zimler
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Attila Tamás Zimler 2011-10-15 05:05:14 UTC
Created attachment 700 [details]
Screenshot of the bug.

See attached screeshot
Comment 1 Alan McGovern 2011-11-15 11:52:15 UTC
chris says that this has happened when only 1 product is being updated, for example when it was just the mono framework itself.
Comment 2 Alan McGovern 2011-11-25 06:51:51 UTC
I can repro this issue, fixing it now.
Comment 3 Alan McGovern 2011-11-25 07:49:35 UTC
This has already been fixed and will be part of the next release. Thanks!
Comment 4 Alan McGovern 2011-12-05 15:24:03 UTC
This bug hasn't been fixed completely. It just appeared when I tried installing updates from m4a, MD 2.8.4.1 and MT.
Comment 5 Mikayla Hutchinson [MSFT] 2011-12-30 19:38:46 UTC
*** Bug 2682 has been marked as a duplicate of this bug. ***
Comment 6 Mikayla Hutchinson [MSFT] 2011-12-30 19:39:26 UTC
I think this only happens when the updater restarts MD.
Comment 7 Jackson Harper 2012-01-01 14:01:48 UTC
Not sure if this has anything to do with it, but it might be because I usually opt out of M4A updates.
Comment 8 Mikayla Hutchinson [MSFT] 2012-01-19 20:32:08 UTC
*** Bug 2539 has been marked as a duplicate of this bug. ***
Comment 9 Mikayla Hutchinson [MSFT] 2012-01-19 20:34:34 UTC
Fixed. This happened because the updater attempted to terminate MonoDevelop and apps from within the MD app bundle, but did not exclude itself.