Bug 15033 - System.IO.DirectoryNotFoundException occurs in Release mode for native binding library
Summary: System.IO.DirectoryNotFoundException occurs in Release mode for native bindin...
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: Bindings ()
Version: 4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Atsushi Eno
URL:
Depends on:
Blocks:
 
Reported: 2013-09-27 04:15 UTC by Julien
Modified: 2017-09-02 11:47 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Julien 2013-09-27 04:15:03 UTC
Hi reader,

I'm trying to build my solution in release mode but I can't figure out this issue.

C:\Program Files\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): 
Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.DirectoryNotFoundException: Could not find a part of the path "[path]\obj\Release\__library_projects__\[My lib]\library_project_imports\[MyJAR].jar" (XA0000) 


I browse to the corresponding folder and it is empty, the same one in debug folder is full of jar files


A colleague of mine uses mac Version of Xamarin and he doesn't have this problem.


thanks for reading me.

Julien
Comment 1 juli 2013-11-18 18:04:59 UTC
We are having this same issue for a referenced java binding library project
(Singly SDK).

I only happens on Windows. On Mac works perfectly.

Issue:

C:\Program Files
(x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error
XA0000: Unexpected error - Please file a bug report
athttp://bugzilla.xamarin.com. Reason: System.IO.DirectoryNotFoundException:
Could not find a part of the path
"{path}\Murally.Android\obj\Debug\__library_projects__\SinglyAndroidSDK\library_project_imports\SinglyAndroidResources\bin\classes\com\singly\android\client\AuthenticationActivity$AuthenticationWebChromeClient.class"
(XA0000) (Murally.Android)

Versions:

Xamarin Studio
Version 4.2.1 (build 1)
Installation UUID: 30866470-afb8-411d-a069-5497fcc64c15
Runtime:
    Microsoft .NET 4.0.30319.18051
    GTK+ 2.24.20 theme: MS-Windows
    GTK# (2.12.0.0)

Xamarin.Android
Version: 4.8.3 (Indie Edition)
Android SDK: C:\Users\Daniela\AppData\Local\Android\android-sdk
    Supported Android versions:
        2.1   (API level 7)
        2.2   (API level 8)
        2.3   (API level 10)
        3.1   (API level 12)
        4.0   (API level 14)
        4.0.3 (API level 15)
        4.2   (API level 17)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode, sharing)

Build Information
Release ID: 402010001
844a84fe0aa0cb5f986d4e3c4807a51487d07845
Build date: 2013-11-13 16:45:15Z
Xamarin addins: 97e44e4863da6c479427794457637e75b3d22600

Operating System
Windows 6.2.9200.0 (64-bit)
Comment 2 Atsushi Eno 2013-12-11 08:02:29 UTC
I tried some projects to build in Release mode but I couldn't reproduce the issue. Do they build on Debug mode?

For comment #1 case I rather doubt it is caused by "path too long" issue, which might be resolved if the project {path} is short.
Comment 3 Atsushi Eno 2014-02-05 06:00:08 UTC
While we will eventually fix possible path too long issue, this particular bug needs input on whether it works or not with "Debug" build (which is 2 characters less than "Release") or in any shorter path.
Comment 4 Kent Green [MSFT] 2017-06-29 23:16:34 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!
Comment 5 v3locim 2017-09-02 11:47:58 UTC
I would suggest to try "Long Path Tool" program.