Bug 14979 - Not seeing all build host in 'Connect to Xamarin.iOS build host' window
Summary: Not seeing all build host in 'Connect to Xamarin.iOS build host' window
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.6.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-09-25 07:24 UTC by narayanp
Modified: 2015-01-05 11:20 UTC (History)
9 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2013-09-25 07:24:00 UTC
Steps to reproduce this issue:
1. Open VS.
2. got to Tools->Options->Xamarin->iOS Settings
3. Click on Configuration.


Actual result: Some build host not displaying in 'Connect to Xamarin.iOS build host' window while all build host are having same Xcode, Firewall- OFF, Same version of X.iOS and Mono even same license as well on windows and Mac.

Note: we have also checked this after deleting values and keys from Registry Edit(regedit) for MonoTouchVS on windows

Expected Result: All build host should displayed in 'Connect to Xamarin.iOS Build host' 

Supplement info: http://screencast.com/t/XnpII097

Environment details:
All Mac(Lion 10.7.4, 107.5, Mountain Lion 10.8.5, 10.8.4, Mavericks 10.9)
Xcode 5 and 4.6.2
X.iOS 7.0.2.5
iOS for VS 1.5.369
Mono 3.2.3
VS 2012/2010
Comment 1 GouriKumari 2013-10-04 18:41:30 UTC
Retested with Xamarin.iOS 1.6.53. I couldn't reproduce this issue. Marking this bug as resolved fixed. Please reopen it incase the issue persisits. 

Actual Result: Build Hosts are getting displayed in  "Connect to a Xamarin.iOS Build Host Window"

Supplemental Info:
http://screencast.com/t/rijBfy4q7Gw

Environment Details:

Xamarin.iOS 1.6.53
VS 2012
Comment 2 Prashant manu 2013-10-07 10:46:00 UTC
Today I have checked this issue with following builds:

All Windows
VS 2012/2010
iOS for VS 1.6.57

Now we are getting all build host in 'Connect to a Xamarin.iOS Build Host' window. This is the screencast for the same: http://screencast.com/t/7bFGhZmfF2

Changing the status to Verified.