Bug 14927 - [iOS 7 simulator only] Issues with "NavBarDemo" iOS sample.
Summary: [iOS 7 simulator only] Issues with "NavBarDemo" iOS sample.
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 7.0.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Oleg Demchenko
URL:
Depends on:
Blocks:
 
Reported: 2013-09-23 10:58 UTC by Saurabh
Modified: 2014-01-21 14:59 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
NavBardemo (9.14 KB, application/zip)
2013-09-23 10:58 UTC, Saurabh
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Saurabh 2013-09-23 10:58:13 UTC
Created attachment 4959 [details]
NavBardemo

Issue 1: With iOS 7.0 simulator, Title of the page does not appear in header.

Step to reproduce:
1. Open NavBarDemo sample
2. Run the application on iOS 7 simulator
3. Click on any tab (like one, two, three or four)

Actual result:
Observe that Title of the page does not appear in header. However, on iOS 6.1 simulator title of the page appear in header. 

Expected result:
On iOS 7 simulator title of the page should appear in header similar as in iOS 6.1 simulator.

Screencast:
For iOS 7 simulator: http://screencast.com/t/7MGN7C3fLTcR
For iOS 6.1 simulator: http://screencast.com/t/1fgFGWmeOGgo

Note: This issue exist only on iOS 7.0 simulator. However, on iPhone4 iOS 7 it is working fine and title of the page should appear in header.

Issue 2: Header Background color does not change to Red on iOS 7 Simulator.

Step to reproduce:
1. Open NavBarDemo sample
2. Open CustonNavBar.cs file
3. Change public CustomNavBar (IntPtr h) to 'public CustomNavBar (IntPtr h) : base (h)' 
4. Change 'BackgroundColor = UIColor.Red;' to 'TintColor = UIColor.Red;'
5. Run the application on iOS 7 simulator

Actual result:
Observe that Header Background color does not change to Red on iOS 7 Simulator. However, on iOS 6.1 simulator Header Background color changes to Red.

Expected result:
Header Background color should change as Red on iOS 7 Simulator.

Screencast:
For iOS 7 simulator: http://www.screencast.com/t/nWgLA7L4
For iOS 6.1 simulator: http://screencast.com/t/iGWtj01TdCD

Note: This issue exist only on iOS 7 simulator. However, on iOS 7.0 and iOS 6.1.3 device it is working fine and background color changes to Red.

Environment info:
=== Xamarin Studio ===

Version 4.0.13 (build 37)
Installation UUID: b1fc3b76-cf00-405e-a0a1-3839ac11fe6d
Runtime:
	Mono 3.2.3 ((no/8d3b4b7)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302030000

=== Apple Developer Tools ===

Xcode 5.0 (3332.22)
Build 5A1412

=== Xamarin.iOS ===

Version: 7.0.0.11 (Enterprise Edition)
Hash: aa35ba3
Branch: 
Build date: 2013-18-09 16:42:48-0400

=== Xamarin.Android ===

Version: 4.8.3 (Enterprise Edition)
Android SDK: /Users/apple/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Xamarin.Mac ===

Xamarin.Mac: 1.6.13

=== Build Information ===

Release ID: 400130037
Git revision: c66520a8992149ce9ceb50106fd3b85b74904704
Build date: 2013-09-18 12:26:11+0000
Xamarin addins: a6908312c9ad3e40f09ad731f444cad06ddf1546

=== Operating System ===

Mac OS X 10.9.0
Darwin Apples-iMac.local 13.0.0 Darwin Kernel Version 13.0.0
    Fri Sep 13 23:35:55 PDT 2013
    root:xnu-2422.1.72~1/RELEASE_X86_64 x86_64
Comment 1 GouriKumari 2013-12-06 19:06:11 UTC
Saurabh,

Can you let me know the source of this sample. I am not able to find it in mobile/monotouch-samples.

However, the error does occur in iOS7 device as well.
Comment 3 GouriKumari 2014-01-07 16:08:19 UTC
I tested with Content Controls iOS sample and is working fine in the following environment.

Test Env:
Xamarin Studio
Version 4.3.0 (build 52)
Installation UUID: 5ed3a124-4b77-4c6f-beb9-c830fd815e2a
Runtime:
	Mono 3.2.5 ((no/964e8f0)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302050000

Apple Developer Tools
Xcode 5.0.1 (3335.23)
Build 5A2053

Xamarin.iOS
Version: 7.0.6.166 (Enterprise Edition)
Hash: eac7b15
Branch: 
Build date: 2013-16-12 16:06:53-0500

Device info: iOS 7 simulator/ iPodTouch 7.0.4
Comment 4 Oleg Demchenko 2014-01-21 14:59:45 UTC
Can't reproduce this issue with Content Controls in the following environment.
Screencast: http://screencast.com/t/l4QpP67GJIAw

OS X 10.9.1
Xamarin Studio 4.3.0
Xamarin.iOS 7.0.6.167
Device info: iOS 7 simulator/ iPad2 7.0.4