Bug 14910 - Google Play Services component doesn't compile
Summary: Google Play Services component doesn't compile
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Bindings ()
Version: 4.8.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Tom Opgenorth
URL:
Depends on:
Blocks:
 
Reported: 2013-09-21 21:04 UTC by Jérémie Laval
Modified: 2014-01-09 05:07 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jérémie Laval 2013-09-21 21:04:25 UTC
/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets (_CompileJava target) ->

	obj/Debug/android/src/mono/com/google/android/gms/plus/PlusClient_OnPersonLoadedListenerImplementor.java(8,41):  javacerror :  cannot find symbol
symbol  : class OnPersonLoadedListener
location: class com.google.android.gms.plus.PlusClient
		com.google.android.gms.plus.PlusClient.OnPersonLoadedListener

	obj/Debug/android/src/mono/com/google/android/gms/games/multiplayer/realtime/RoomStatusUpdateListenerImplementor.java(4,8): error :  mono.com.google.android.gms.games.multiplayer.realtime.RoomStatusUpdateListenerImplementor is not abstract and does not override abstract method onP2PDisconnected(java.lang.String) in com.google.android.gms.games.multiplayer.realtime.RoomStatusUpdateListener
public class RoomStatusUpdateListenerImplementor
Comment 1 Jérémie Laval 2013-09-21 21:08:19 UTC
=== Xamarin Studio ===

Version 4.1.7 (build 1289)
Installation UUID: 9f043368-f776-409e-8ffd-efbda48219aa
Runtime:
	Mono 3.2.1 ((no/f3f789e)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302010001

=== Apple Developer Tools ===

Not Found

=== Xamarin.iOS ===

Version: 6.9.6.0
Hash: d46e8f2
Branch: 
Build date: 2013-19-08 09:52:00-0400

=== Xamarin.Android ===

Version: 4.8.2 (Business Edition)
Android SDK: /Users/jeremie/mono/android-sdk-macosx
	Supported Android versions:
		1.6   (API level 4)
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
Java SDK: /usr
java version "1.6.0_51"
Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

=== Xamarin.Mac ===

Xamarin.Mac: 1.2.36

=== Build Information ===

Release ID: 401071289
Git revision: 28fdb6d77d0600e7acc7aa15a1428a179f70dcba
Build date: 2013-09-20 19:24:41+0000
Xamarin addins: 0006bd8ca026b364688989a4e6e8047a61689690

=== Operating System ===

Mac OS X 10.8.5
Darwin phoenix 12.5.0 Darwin Kernel Version 12.5.0
    Mon Jul 29 16:33:49 PDT 2013
    root:xnu-2050.48.11~1/RELEASE_X86_64 x86_64
Comment 2 Tom Opgenorth 2013-09-22 11:31:35 UTC
This type of problem usually happens when you have a mismatch between your Google Play Services component and the installed version of the Google Play Client SDK installed. For example, you are using rev 10 of the Google Play Services component, but only have rev 9 of the Google Play services library installed. 

Currently our component targets Google Play services rev 10, and I see that as of 22-Sep-2013 that Google has update the Google Play services library to rev 12, which is causing the breakage.

We do have a fix for this that should be available in Xamarin.Android 4.8.3. 

In the mean time there are two workarounds for this:

1.) Revert back to Google Play services rev 10. You can download it from https://dl-ssl.google.com/android/repository/google_play_services_3225130_r10.zip. Unzip this to the $ANDROID_HOME/extras/google directory.

2.) Create your own manual binding for Google Play Services.
Comment 3 Jérémie Laval 2013-09-23 12:00:28 UTC
Reverted to rev10, still getting the compilation error with onP2PDisconnected.

This looks like a regression.
Comment 4 Tom Opgenorth 2013-09-23 13:25:58 UTC
Tried to duplicate this, and I can't (i.e. used Android SDK to upgrade to Google Play Services rev 12, then manually downgraded to rev 10).

Can you try manually deleting the obj & bin directories from the Xamarin.Android project and try again?

Any chance you can attach a test case?
Comment 5 Jérémie Laval 2013-09-23 20:38:06 UTC
You need to use an alpha/beta/master build of Xamarin.Android
Comment 6 chetan 2013-09-24 08:18:25 UTC
Hi Tom Opegenorth,

After following this fixation 

1.) Revert back to Google Play services rev 10. You can download it from
https://dl-ssl.google.com/android/repository/google_play_services_3225130_r10.zip.
Unzip this to the $ANDROID_HOME/extras/google directory.

The below error is coming in Visual Studio 2012:

Error	1	Please install package: 'Google Play services' available in SDK installer. Android resource directory C:\Program Files (x86)\Android\android-sdk/extras/google/google_play_services/libproject/google-play-services_lib doesn't exist.	googlemap_2
Error	2	Please install package: 'Google Play services' available in SDK installer. Java library file C:\Program Files (x86)\Android\android-sdk/extras/google/google_play_services/libproject/google-play-services_lib/libs/google-play-services.jar doesn't exist.	googlemap_2



And the Android SDK shows that the Google Play Services v 12 is not installed.
Comment 7 chetan 2013-09-24 09:07:35 UTC

Compiled using Android Version : 3.1
Minimum Androis to target : 2.2
Target Androis Version : 4.0
Comment 8 Tom Opgenorth 2013-09-24 09:35:33 UTC
Chetan: Check the contents of C:\Program Files
(x86)\Android\android-sdk/extras/google. It probably has the folder google-play-services, instead of google_play_services.

Just rename the folder, replacing the - with _.
Comment 9 chetan 2013-09-25 07:26:10 UTC
Thanks Tom Opgenorth
Comment 11 Tom Opgenorth 2013-10-04 18:16:28 UTC
Problem was eventually resolved once problems in AndroidManifest.xml were identified and corrected.