Bug 14865 - [Windows 7*64] Android designer is broken.
Summary: [Windows 7*64] Android designer is broken.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Designer ()
Version: 4.0.13
Hardware: PC Windows
: High major
Target Milestone: 4.0.13 (XCode5)
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2013-09-19 14:54 UTC by Akhilesh kumar
Modified: 2013-09-26 03:03 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Akhilesh kumar 2013-09-19 14:54:28 UTC
Step to reproduce:
1. Open XS
2. Create Android Application template
3. Open Main.axml android designer  

Actual result:
Observe that android designer page does not open in XS correctly and gives error 'Android version not supported by the designer'.

Expected result:
Android designer page should open in XS successfully without any error.

Screencast: 
http://screencast.com/t/93Fm4FRpWPA
http://screencast.com/t/hULgAWwpQv

Error details: https://gist.github.com/AkhileshKumar01/7f3b2cbdca84a07140d2

Note: This issue exist only on Windows 7*64. However, on Windows 7*32 and Windows 8*32 this issue does not exist.

Environment details:(Not working)
=== Xamarin Studio ===

Version 4.0.13 (build 37)
Installation UUID: d31d8145-d1a3-43f9-85f0-00a3824d6010
Runtime:
	Microsoft .NET 4.0.30319.18331
	GTK+ 2.24.20 theme: MS-Windows
	GTK# (2.12.0.0)

=== Xamarin.Android ===

Version: 4.8.2 (Trial Edition)
Android SDK: D:\Xamarin\MonoForAndroid\AndroidSDK
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
Java SDK: C:\Program Files (x86)\Java\Jdk 1.7.0_25
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Build Information ===

Release ID: 400130037
c66520a8992149ce9ceb50106fd3b85b74904704
Build date: 2013-09-18 08:55:29Z
Xamarin addins: a6908312c9ad3e40f09ad731f444cad06ddf1546

=== Operating System ===

Windows 6.1.7601.65536 (64-bit)

*********************************

Working environments:
Windows 8*32 - https://gist.github.com/AkhileshKumar01/2d43dd286602c8e7b4af
Windows 7*32 - https://gist.github.com/AkhileshKumar01/6b26aab1f113c36443ea
Comment 1 PJ 2013-09-19 15:41:33 UTC
This is likely due to the selection of 4.3 as the default target framework, which is happening on this machine because it has Android 18 (4.3) installed.

Akhilesh do the other machines have 4.3 installed?
Comment 2 PJ 2013-09-19 15:43:11 UTC
Whoops, you added them at the end - nice! Ok, investigating.
Comment 3 PJ 2013-09-19 16:22:20 UTC
Hrm, I'm getting a different error:

https://gist.github.com/pjbeaman/f57d8ce0b64a3e217e7d

http://screencast.com/t/ymMxwrOp3

Here's my version information: https://gist.github.com/pjbeaman/724dcb7bd73790a4400f

I downgraded to 4.8.2 and get the same behavior.  I'm going to try the upgrade to Java 1.7 and see if that's the difference. I doubt that's it though.

Trying to set the 1.7 Java JDK gives me https://bugzilla.xamarin.com/show_bug.cgi?id=14869 so I'll try renaming the 1.6 JDK so it cant' be found.

That worked, Java 1.7 is now saving as the SDK location. Same behavior though.

So yeah, I'm further behind on this than you guys are, can't even get to the error you're seeing. Can't really confirm your issue as I have my own.

=> Lluis

Let me know if you want me to paste my issue into a new bug Lluis.
Comment 4 Lluis Sanchez 2013-09-20 06:52:27 UTC
This seems to be caused by the latest Android SDK update. Still trying to find out how to fix.
Comment 5 Nischal 2013-09-26 03:03:25 UTC
Today we have checked this issue after updating our SDK with following builds :

XS 4.0.13 (build 39)
X.Android 4.8.03003

Now we are able to open Android designer successfully when default API level is 4.3 (v18).
Hence closing this issue.