Bug 14757 - configure for extras/ValaBinding fails if mono-addins-setup is not installed, but that
Summary: configure for extras/ValaBinding fails if mono-addins-setup is not installed...
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Vala Binding ()
Version: Trunk
Hardware: PC Linux
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-09-14 17:05 UTC by Justin Dearing
Modified: 2014-02-17 15:12 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Justin Dearing 2013-09-14 17:05:45 UTC
If I configure ValaBindings on a machine with mono, but not mono-addins installed I get the following:


Configuring package: extras/ValaBinding
---------------------------------------
<snip/>
checking for MONO_ADDINS... yes
checking for MONO_ADDINS_SETUP... configure: error: Package requirements (mono-addins-setup >= 0.3) were not met:

No package 'mono-addins-setup' found

However, mono-addins-setup is one of the externals provided by monodevelop. Its not currently built automatically by mono-develop. Shouldn't it be built automatially, and the check removed from ValaBinding configuration?
Comment 1 Lluis Sanchez 2014-02-17 15:12:50 UTC
We don't support this binding anymore.