Bug 14752 - Mono build error
Summary: Mono build error
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-09-14 09:13 UTC by alex
Modified: 2013-09-14 15:10 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description alex 2013-09-14 09:13:54 UTC
Just pulled the latest changes from the mono repo.

Make gave me

make[3]: Entering directory `/run/media/lx/Home.alt/lx/Dokumente/Projects/mono/mono/mini'
  CC       libmini_la-mini.lo
mini.c: In Funktion »mono_emit_jit_map«:
mini.c:5630:44: Error: »MonoJitInfo« does not contain element »method«
   char *name = mono_method_full_name (jinfo->method, TRUE);
Comment 1 Zoltan Varga 2013-09-14 15:10:18 UTC
Fixed.