Bug 14726 - Visual Studio 2012 doesn't show IOS simulator as an option of device
Summary: Visual Studio 2012 doesn't show IOS simulator as an option of device
Status: RESOLVED FEATURE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.3.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-09-13 14:42 UTC by Jon Goldberger [MSFT]
Modified: 2013-10-08 10:43 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
VS Logs (4.75 KB, application/zip)
2013-09-13 14:42 UTC, Jon Goldberger [MSFT]
Details
mtbserver.log (94.43 KB, application/octet-stream)
2013-09-13 16:04 UTC, Jon Goldberger [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FEATURE

Description Jon Goldberger [MSFT] 2013-09-13 14:42:48 UTC
Created attachment 4870 [details]
VS Logs

Hi, I have an App in Xamarin Android so now I want to create the iOS
version. 



The first problem I found is that Visual Studio 2012 doesn't show IOS
simulator as an option of device, I can only see "No devices Attached" but
the connection with the MAC seems to be ok, if I press the button "Show iOS
Simulator" the MAC acts as is expected and shows the simulator. 



So my question is how can I attach the iOS simulator in Visual Studio? Also
I tried changing the project options and selected iOS Simulator as a
platform for Debug and it doesn't help.
------------------------------------------------------------------------
Comment 2 Jon Goldberger [MSFT] 2013-09-13 16:04:07 UTC
Created attachment 4871 [details]
mtbserver.log
Comment 3 Dominique Louis 2013-09-14 11:28:54 UTC
Hi Jon,
  Once you switch the Solution Platform from iPhone to iPhone Simulator, it should list all the simulators. If after a few seconds they are not listed, then please check that you have installed XCode correctly.


D.
Comment 4 PJ 2013-10-08 10:43:12 UTC
Dominique, it sounds like you've correctly identified the issue, resolving as FEATURE (although we could probably handle this better).

Jon, it displays that message when there are no *physical* devices attached, he's got to switch to simulator like you say.