Bug 14617 - Binding iOS Library - Error MT5202 - native linking failed. please review the build log. (MT5202)
Summary: Binding iOS Library - Error MT5202 - native linking failed. please review the...
Status: RESOLVED INVALID
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 6.9.5.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-09-10 14:04 UTC by Jon Goldberger [MSFT]
Modified: 2013-09-25 08:18 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Build Log (97.14 KB, text/plain)
2013-09-10 14:04 UTC, Jon Goldberger [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Jon Goldberger [MSFT] 2013-09-10 14:04:30 UTC
Created attachment 4830 [details]
Build Log

While attempting to bind an iOS library that I created that is quite simple and presents a view from a xib. I followed the tutorial here: http://docs.xamarin.com/guides/ios/advanced_topics/binding_objective-c/binding_walkthrough

However, when trying to build the test project I get the error:  "native linking failed. please review the build log. (MT5202)"

Here is the build log for the project. The issue seems to be many "duplicate symbols." 
<Build log too big for here, attached as text file>
Comment 3 Rolf Bjarne Kvinge [MSFT] 2013-09-25 08:18:18 UTC
The problem is that the native library has been incorrectly built for the i386 architecture. Every i386 object file is duplicated.

> lipo  libEADemoViewSDK.a  -thin i386 -output libEADemoViewSDK.i386.a

> ar -t libEADemoViewSDK.i386.a | sort
EAAddressViewController.o
EAAddressViewController.o
EAEmailViewController.o
EAEmailViewController.o
EAGeneralInformationViewController.o
EAGeneralInformationViewController.o
EAPhoneViewController.o
EAPhoneViewController.o

Which explains all the duplicated symbols.