Bug 14590 - System.NullReferenceException at System.ServiceModel.ChannelFactory.get_DefaultOpenTimeout ()
Summary: System.NullReferenceException at System.ServiceModel.ChannelFactory.get_Defau...
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 6.4.4
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-09-10 05:31 UTC by Prashant Cholachagudda
Modified: 2017-03-22 12:45 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case (3.40 MB, application/zip)
2013-09-10 05:31 UTC, Prashant Cholachagudda
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Prashant Cholachagudda 2013-09-10 05:31:47 UTC
Created attachment 4819 [details]
Test case

NRE when we call webmethod

Error stacktrace:
System.NullReferenceException: Object reference not set to an instance of an object
at System.ServiceModel.ChannelFactory.get_DefaultOpenTimeout () [0x00000] in /Developer/MonoTouch/Source/mono/mcs/class/System.ServiceModel/System.ServiceModel/ChannelFactory.cs:85
at System.ServiceModel.MonoInternal.ClientRuntimeChannel..ctor (System.ServiceModel.Description.ServiceEndpoint endpoint, System.ServiceModel.ChannelFactory channelFactory, System.ServiceModel.EndpointAddress remoteAddress, System.Uri via) [0x00000] in /Developer/MonoTouch/Source/mono/mcs/class/System.ServiceModel/System.ServiceModel/ClientRuntimeChannel.cs:90
at System.ServiceModel.ClientBase`1+ChannelBase`1[ExtranetWebServiceSoap,ExtranetWebServiceSoap].get_Inner () [0x0000b] in /Developer/MonoTouch/Source/mono/mcs/class/System.ServiceModel/System.ServiceModel/ClientBase.cs:381
at System.ServiceModel.ClientBase`1+ChannelBase`1[ExtranetWebServiceSoap,ExtranetWebServiceSoap].Invoke (System.String methodName, System.Object[] args) [0x0003c] in /Developer/MonoTouch/Source/mono/mcs/class/System.ServiceModel/System.ServiceModel/ClientBase.cs:392
at ExtranetWebServiceSoapClient+ExtranetWebServiceSoapChannel.CaseNotification (System.String contactName, System.String contactValue, System.String caseType, System.String subject, System.String description, System.String preferedContactMethod, System.String securityToken) [0x0002f] in /Users/wcdev/Projects/Extranet/Extranet/Service References/wchostwebapp02.myoffice.dom/Reference.cs:80
at ExtranetWebServiceSoapClient.CaseNotification (System.String contactName, System.String contactValue, System.String caseType, System.String subject, System.String description, System.String preferedContactMethod, System.String securityToken) [0x00012] in /Users/wcdev/Projects/Extranet/Extranet/Service References/wchostwebapp02.myoffice.dom/Reference.cs:50
at Extranet.RequestCaseScreen.btnRequestCase_Click (MonoTouch.Foundation.NSObject sender) [0x0005e] in /Users/wcdev/Projects/Extranet/Extranet/RequestCaseScreen.cs:57
at at (wrapper managed-to-native) MonoTouch.UIKit.UIApplication:UIApplicationMain (int,string[],intptr,intptr)
at MonoTouch.UIKit.UIApplication.Main (System.String[] args, System.String principalClassName, System.String delegateClassName) [0x0004c] in /Developer/MonoTouch/Source/monotouch/src/UIKit/UIApplication.cs:38
at Extranet.Application.Main (System.String[] args) [0x00008] in /Users/wcdev/Projects/Extranet/Extranet/Main.cs:16
Comment 3 Manuel de la Peña [MSFT] 2017-02-13 17:43:03 UTC
@Prashant is this issue valid? Can you update the attached test case for it to build with the latests Xamarin release to be able to test the platform and triage the bug accordingly. Thanks.
Comment 4 Manuel de la Peña [MSFT] 2017-03-22 12:45:57 UTC
We have not received the requested information. If you are still 
 experiencing this issue please provide all the requested information 
 and re-open the bug report. Thanks!